Ask Your Question
1

LibreOffice 5.2.0.4 unbearably slow on Ubuntu 14.04

asked 2016-08-13 19:29:00 +0200

alk224 gravatar image

I have been using LibreOffice for years, but recently it has become practically unusable. It doesn't matter if I am using Calc or Writer or Impress, it has become so incredibly slow. For instance, if I open a tab-delimited file in Calc, I might have to wait 30 seconds or more for Libre to become responsive. Then if I click on a cell, there is 10 seconds or so of lag before it is visibly highlighted. Meanwhile it seems to be slowing other things on the computer. I tried searching for "LibreOffice slow ubuntu" in my browser during one of these lag spells and the browser hung and my text got entered all out of order. I need to be able to work on documents and spreadsheets on my Linux systems, but this is ridiculous.

I have found a few posts on the web suggesting to increase available RAM and delete history. None of this works, and none of it should need to be done anyway. I suspect the problem is a graphics rendering issue, especially given that my browser was lagging while LibreOffice was putting the brakes on my system. I have an Apple MacPro (2012) running Ubuntu 14.04 (no mac OS) and an Nvidia Quadro FX 1700 graphics card. I have this problem whether I use proprietary Nvidia drivers or the Nouveau driver.

I really like LibreOffice, but this problem makes it unusable, and no good solution seems to exist. Further, I find posts from people complaining of similar issues going back at least 5 years so it is likely a bug which has been present a long time but only manifests under certain hardware/software configurations.

edit retag flag offensive close merge delete

Comments

I am also having problems with 5.2.0.4.with Windows Vista I now at the point of going back to 4.4.

Some other points: It seems to run better on Windows XP And it crashes more (on Vista) than it used to. Steve

morsed2 gravatar imagemorsed2 ( 2016-09-13 17:57:14 +0200 )edit

5 Answers

Sort by » oldest newest most voted
1

answered 2016-08-13 19:36:28 +0200

alk224 gravatar image

This is not a good answer, but I have got LibreOffice cooperating again. I had to uninstall and reinstall. I used apt to make the changes and did autoremove in between steps:

sudo apt-get remove --purge libreoffice*

sudo apt-get autoremove

REBOOT SYSTEM

sudo apt-get install libreoffice

And now the lag is gone which I am happy about, but I am very surprised this worked.

edit flag offensive delete link more

Comments

I am surprised as well. My best bet is that you had a program using full CPU until the restart. Use system monitor to see which one.

mahfiaz gravatar imagemahfiaz ( 2016-08-14 08:05:42 +0200 )edit

I was checking this with htop, but nothing seemed to be hogging anything. Plus I have 24 cores, so there should be no want for CPU power. I just opened a spreadsheet and scrolled up and down without issue and without any processes jumping up on htop. That said, I continue to have issues with LibreOffice in general and am not really sure what may be causing the problems.

alk224 gravatar imagealk224 ( 2016-08-30 18:35:02 +0200 )edit

There are a few specific bugs which cause slowdown, e.g this, maybe your case is similar? https://bugs.documentfoundation.org/s...

mahfiaz gravatar imagemahfiaz ( 2016-09-04 07:10:18 +0200 )edit
1

This completely resolved my slow issue. Thanks!!!

ameriviking gravatar imageameriviking ( 2017-02-19 00:56:03 +0200 )edit
1

answered 2017-06-16 02:38:37 +0200

Francewhoa gravatar image

We facing a similar challenge here. When using LibreOffice (LO) Calc 5.2.7.2, adding large amount of text to a text cell result in Calc hangs. Hang ranges from slow to unusable Calc. Same challenge with opening large cells.

I created a bug report using the official LibreOffice ticketing system at https://bugs.documentfoundation.org/s...

If you are also able to reproduce that bug, to speed up a fix, I suggest for all to post a comment to the LibreOffice ticketing system. To let them know this bug is confirmed.

Any volunteers for a patch? I would be happy to contribute testing and documentation if needed. Again, to get a faster response about patch testing I suggest to reply at https://bugs.documentfoundation.org/s...

edit flag offensive delete link more
0

answered 2017-10-25 09:52:58 +0200

None of the memory settings work. I gave it 1GB of memory, without any effect. I have the same issue in Ubuntu 16.06 with Libreoffice 5.1.6.1. My experience is, that libreoffice is getting more worse with every new version.

And deleting the comments cannot be a real solution.

Version 4.x.x ran acceptable and was about much times faster in my case. I am using calc very often. One of my files has many tabs with references to web data. In version 4.x.x, it took about 20 minutes to update about 300 tabs. In LO 5.x.x I often killed LO after 1 hour.

At this moment, I tried to find out, which version is installed. What I see is an empty window with a title for about 10 minutes(!!!) now, but no content at all. :-( The only response from libreoffice is pushing itself into foreground ... about 30 times until now.

Are there any developers in this forum? Do they use their own applications?

edit flag offensive delete link more

Comments

Same problem with Libreoffice 5.4.2.2 on Ubuntu 16.06 .... this office suite is unuseable for me. The aboutbox took more than 5 minutes(!!!!) to show show its content. :-(

nochance gravatar imagenochance ( 2017-11-02 11:11:48 +0200 )edit
0

answered 2016-08-23 16:28:41 +0200

ggoodenough gravatar image

updated 2016-08-23 16:34:59 +0200

I'm running into this same issue. However, the above "solution" does not work. Are there other suggestions?

When I watch top, the soffice.bin process spikes to the top of the list while performing any action (e.g. Resize, move, wheel scroll through the document, clicking on menus).

Any troubleshooting suggestions are much appreciated.

OS: Xubuntu 14.04 LTS

edit flag offensive delete link more
0

answered 2016-10-29 22:09:32 +0200

helper gravatar image

There are many posts on adjusting memory settings. They help - do a search - I tried them. Here is an entirely different finding: Libre Calc does not handle the "comments" feature like Excel. Yes - Libre Calc does not handle the "comments" with 100% compatability. Suggest deleting all comments. Convert them to text in an adjacent cell. Add a row / column for comments - just try not to have them in LibreCalc. In my case, a 150k sheet took 1 minute to save with comments. 1 second without comments. Try it on your xls, xlsx, ods files.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-08-13 19:29:00 +0200

Seen: 2,109 times

Last updated: Oct 25 '17