Ask Your Question

Can I force a particular application to open a file? [closed]

asked 2012-11-05 18:16:54 +0100

jxn gravatar image

updated 2015-11-02 03:56:54 +0100

Alex Kemp gravatar image

I have some powerpoint presentations (with a .ppt file) which I am trying to open in Impress. For some reason, even if I've started Impress and choose Open, or use the Impress wizard, or try to open the file using the impress command line shortcut, they always open in Writer -- or, rather, try to open. It just appears as a jumbled text. It opens fine in powerpoint viewer, so I think the file itself is fine.

Is there any way to try to force impress to open it?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-02 03:57:07.392964



Hmm... that's very bizarre. Could you please tell us your OS and version of LO? Any chance that you could post an example file somewhere that demostrates this behavior?

qubit gravatar imagequbit ( 2013-01-23 21:47:02 +0100 )edit

Would it work if you run from the command line libreoffice -show filename.ppt? Just an idea to try.

carnendil gravatar imagecarnendil ( 2013-11-08 23:47:44 +0100 )edit

This is happening to me with Version: Build ID: 9bb7eadab57b6755b1265afa86e04bf45fbfc644 This is on Windows 7 Home, On Ubuntu 12.04 the same file opens with Impress fine.

Peter Lawrey gravatar imagePeter Lawrey ( 2014-11-04 13:45:00 +0100 )edit

3 Answers

Sort by » oldest newest most voted

answered 2013-02-25 06:18:57 +0100

qubit gravatar image

Hi @jxn,

If installing the latest release doesn't seem to fix this problem, please file a bug and provide a list of steps that can reproduce it. Please make sure to attach an example file or two that demonstrate this behavior. That will help us to determine if this problem is specific to particular machines, particular OSes, etc..

The QA team will be happy to help you track down this issue! Please post a link to any bugs you file in a comment below using the format "fdo#123456".


edit flag offensive delete link more

answered 2013-11-08 14:56:52 +0100

pierre gravatar image

updated 2013-11-08 14:58:16 +0100

Hi, I have the same, when I try to open antique ppt that I created long ago in microsoft powerpoint before y2k. It does not appear with more modern ppt --> My guess is that it happens with older formats (ppt 2, 6, 95, 97, 2000 seem to be different formats, after all) NB I can't find the link to attach file, otherwise you could experiment with it :-(

edit flag offensive delete link more


Was your problem solved? I can see the same using Windows 8.1 and LO4.3.4 (even with 4.2.5, that i have uninstalled and installed 4.3.4, but it didn't help). I try to open a PPT created in 1997. It opens in Writer instead of Impress. I deleted the registry entries for ppt and pptx in HKEY_CLASSES_ROOT, still same - Writer opens the file.

matalan1 gravatar imagematalan1 ( 2014-12-07 10:40:37 +0100 )edit

answered 2013-01-24 05:16:29 +0100

ROSt52 gravatar image

I recently opened an LibO file (forgot which application) after removing the extension and just double click on it. It opened correctly.

You could also see what happens when you delete the file extension.

Lib 3.5/7 or LibO 3.6.4 on XP/SP3

edit flag offensive delete link more


even if i removed the extension, selected simpress.exe to open the file, it opens with Writer instead! Very strange.

matalan1 gravatar imagematalan1 ( 2014-12-07 10:49:31 +0100 )edit

Question Tools


Asked: 2012-11-05 18:16:54 +0100

Seen: 604 times

Last updated: Nov 08 '13