Ask Your Question
0

How do I prevent 'E' from automatically formatting as standard form [closed]

asked 2012-11-06 11:56:07 +0200

James Haigh gravatar image

Background: I made a spreadsheet and one of the columns is in units of V (volts). Since 0.224 is easier to read than 2.24E-001, for example, I have formatted this particular column as General (most of the columns are formatted as 0.00E+0). However, the data I'm entering is easier to enter using 'E' (or just 'e'). For example 41.5µA (microamps) is best entered as 41.5e-6, and 224mV (millivolts) can be entered as 224e-3. Unfortunately though, using E when entering data automatically changes the number format to 0.00E+000.

So the question is, how do I prevent the use of E when entering data from changing the number format?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-18 22:21:18.574657

1 Answer

Sort by » oldest newest most voted
0

answered 2012-11-06 12:01:48 +0200

James Haigh gravatar image

updated 2012-11-06 12:21:39 +0200

Figured it out!

Any other number format is not automatically changed; it's almost like General is a 'blank' number format. Ie. formatting as General is equivalent to clearing the number format.

So the solution is to format as General;General, which is equivalent to General in function, but is not a 'blank' number format so is not changed to standard form.

edit flag offensive delete link more

Comments

Unfortunately, General"" doesn't persist across saves!!

James Haigh gravatar imageJames Haigh ( 2012-11-06 12:18:15 +0200 )edit

But General;General does. ;-)

James Haigh gravatar imageJames Haigh ( 2012-11-06 12:20:05 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2012-11-06 11:56:07 +0200

Seen: 221 times

Last updated: Nov 06 '12