Ask Your Question
0

PDFs get re-routed to open in Writer instead!?!?

asked 2016-08-25 00:27:25 +0200

jaycee gravatar image

Hi,

I have debian jessie, newly installed with the latest libreoffice suite.

Back when I had fedora 21, libreoffice draw used to open the PDFs. However, on debian, I click on a PDF and the file is opened instead in libreoffice writer. The file however is not recognized as being a PDF so what is opened is the literal contents of the PDF file.

Even if I open libreoffice draw via command line (using sdraw program), it still re-directs the file to be opened in writer, how do I fix this?

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2020-04-06 11:19:37 +0200

updated 2020-04-06 11:20:03 +0200

Version: 5.2.7.2 Build ID: 1:5.2.7-1+deb9u11 uname -a Linux devuan 4.9.0-12-amd64 #1 SMP Debian 4.9.210-1 (2020-01-20) x86_64 GNU/Linu

The same problems occuers here. File manager, right click, open in Draw, opens in writer. Draw, open file, pdf, switches to writer as well.

On other machines I had to issues with this.

IS there a workaround?

edit flag offensive delete link more

Comments

This is not an answer to the initial question. You should have added a comment (but it would not have "refreshed" the question to push it at head of question list) or asked a new question, citing this one in a link.

When you ritght-click on the file icon, what does the Open with… menu say? In which order are the target applications listed?

Definitive answer depends on your desktop manager. Which one are you using? GNOME? MATE? KDE Plasma? A lightweight one like Xfce or LXDE?

ajlittoz gravatar imageajlittoz ( 2020-04-06 11:34:02 +0200 )edit

The problems isn't what is showing up in the right click menu; it shows Draw. Draw automatically came up in the right click menu after I installed Libreoffice. The problem is that, if I open a PDF with Draw, no matter what way, they open in Writer instead of Draw.

I use PCManFM 1.2.5 on Openbox.

Right click menu; Firefox ESR xpdf LO Draw Open with...

japieapie gravatar imagejapieapie ( 2020-04-06 13:14:16 +0200 )edit

It opens in Writer in what way? does it look like the normal PDF contents, or is it shown as PDF codes? (in which case it could be an issue with system poppler maybe?)

Mike Kaganski gravatar imageMike Kaganski ( 2020-04-06 20:58:48 +0200 )edit

It opens indeed as PDF codes in Draw. In xpdf it opens normally, how the pdf was designed.

japieapie gravatar imagejapieapie ( 2020-04-06 22:45:58 +0200 )edit

@japieapie: "indeed"? "in Draw"?

Normally LibreOffice is able to open PDFs both in Draw and in Writer, both looking as designed. However, if your LibreOffice instance has broken PDF import, it would not recognize the PDF, and then would treat the file as plain text, opening also in Writer, but showing PDF codes instead of the proper view. Thus I suspected that you have possibly some problem with poppler library on your system (which is used by LO to import PDFs); maybe some LibreOffice PDF-related package is missing.

Mike Kaganski gravatar imageMike Kaganski ( 2020-04-07 09:59:24 +0200 )edit

Please excuse me that I don't have all knowledge about it.

I installed poppler-utils, but the issue remains the same. I can't find how to proceed. Could you suggest what the next step could be?

japieapie gravatar imagejapieapie ( 2020-04-08 09:22:36 +0200 )edit

I can't find any solution how to fix this issue. Could somebody maybe provide me a solution or direction where to look for?

japieapie gravatar imagejapieapie ( 2020-04-15 20:05:47 +0200 )edit
0

answered 2016-08-26 15:36:25 +0200

mark_t gravatar image

Which version of LibreOffice do you have installed?

You might try upgrading to a more recent version to see if that corrects the issue. I'm using LibreOffice 5.2.0.4 on Windows 8.1 and confirmed that LibreOffice opens pdf files in Draw.

edit flag offensive delete link more
0

answered 2016-08-27 11:50:18 +0200

petermau gravatar image

Is this not a Debian file manager rather than a LibO setting? On my Linux-Mint Mate system when I wish to change the program used to open the file, I open the file manager (CAJA in my case) and right click on the file in question. Then choose which program I wish to use to open the file and make this the new default.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-08-25 00:27:25 +0200

Seen: 452 times

Last updated: Apr 06