Ask Your Question
0

Can't view some Unicode characters in LO5.1

asked 2016-08-26 10:12:31 +0200

jawlez gravatar image

I recently moved to working with LibreOffice and downloaded the 5.1 version. Previously I would work with MSOffice and there all Unicode charcters I'd use would show with no problems. However, in LO5 some charaters are not displaying properly such as ๐”“ (i think its code is 1D513). I tried changing the font from Palatino Linotype (worked well in MSOffice) to Freefont but nothing doing. What could be the problem?

Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-08-26 13:46:40 +0200

jawlez gravatar image

updated 2016-08-26 14:09:27 +0200

I think on my locale the default is Alt+X. I tried it, i.e. writting the unicode hex digits then pressing Alt+X and I still get some strange symbol, i.e., a rectangular box with a question mark within. it doesn't matter which font I use. :-(

Actually, I found a solution. I tried tinkering with the language settings especially the CTL language. I changed it from the default Arabic to Hebrew and it worked. Don't know why, but anyway... :-)

edit flag offensive delete link more
0

answered 2016-08-26 12:35:31 +0200

Lupp gravatar image

updated 2016-08-26 17:24:52 +0200

(1.) LibO V5.1 introduced toggling between unicode and glyph .
โ€‚โ€‚โ€‚ By default the key for it is 'Alt'+X.
(2.) The format produced by LibO is like "U+1d513", but the code without
โ€‚โ€‚โ€‚ the "U+" is also accepted. So are upper case letters for hex digits above 9.
(3.) On my (standard+) Win-10-system with LibO 5.2.0 none of the installed
โ€‚โ€‚โ€‚ fonts contained the glyph you talked of as an example.
(4.) Google told me the 'FreeSerif' font was good for things like that.
(5.) Having installed it adding to my Win-Fonts LibO automatically created the needed replacement
โ€‚โ€‚โ€‚ also with the default font chosen for the active paragraph.

Please report whether this works for you or (unfortunately) not.

(Editing with respect to the answer by the OQ: The Alt+C was the default setting for de-UI. I changed it to the Alt+X for en-UI.
The mentioned note was https://wiki.documentfoundation.org/R....
A font containing glyphs for the special range of code points used here is indispensable. If the replacement can be locale / language dependent I do not know, but such a dependance is plausible. During one test even my system changed behaviour insofar without any changes ion the settings.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-08-26 10:12:31 +0200

Seen: 427 times

Last updated: Aug 26 '16