Ask Your Question
0

sorting single and double digit numbers

asked 2016-09-01 14:42:14 +0200

polpel gravatar image

I'm trying to sort the whole table by the column L. I've chosen descending order, however it picks 9.89 as a higher value than 79.06; 6.93 as a higher value than 59.26 and so on. I've been suggested to use the 'number format' (button I marked on screenshot), but this doesn't change anything.

What do I need to do in order for this sort to be correct? Below screenshot with marked difficulty.

https://gyazo.com/c7046bf6133859e3fe2...

Thanks!

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2016-09-01 22:22:53 +0200

m.a.riosv gravatar image

Looks as if data was imported from a csv/txt file, on the import window, selecting for every column their type or using i.e. UK English as import language could solve the issue with decimal point so numbers are imported as numbers not as text.

edit flag offensive delete link more

Comments

Thank you, changing the language solved the issue.

polpel gravatar imagepolpel ( 2016-09-02 12:25:51 +0200 )edit
0

answered 2016-09-01 16:48:38 +0200

mark_t gravatar image

updated 2016-09-01 16:49:43 +0200

Use view, value highlighting. Numbers show blue, text in black.

Look for leading or trailing spaces and remove them.

Depending on your language settings you might need , instead of . For decimal point.

Select a cell and check if it begins with ' in the formula entry box, as this forces data as text.

After changing cell format from text to number, any existing data will have ' added which forces the content to still be treated as text until you remove '.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-09-01 14:42:14 +0200

Seen: 307 times

Last updated: Sep 01 '16