Ask Your Question
0

How do I stop it from printing in landscape mode instead of portrait mode? [closed]

asked 2016-09-07 04:37:58 +0100

mylani gravatar image

updated 2016-09-07 08:49:03 +0100

Kruno gravatar image

Documents are formatted properly (like a basic word document that you would read in portrait mode) but when I send it to print from my Epson printer, it flips the document so that it prints in landscape mode which is not how the document is formatted to print. I cannot figure out how to change the settings so that it stops doing that.

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by Kruno
close date 2018-03-14 20:52:46.379123

Comments

What does File → Printer settings → Properties... say?

Kruno gravatar imageKruno ( 2016-09-07 08:50:04 +0100 )edit

I, too, am struggling with this problem. And there IS no choice under file--Printer Settings that would indicate either portrait or landscape. Besides, most of the items in the drop down menus are greyed out.

Cynthia W. gravatar imageCynthia W. ( 2016-10-01 21:39:31 +0100 )edit

For LO 5.4.1.2 on macOS 10.12.6 and osx10.10 (yosemite), I've experienced the 'same issue' with Letter size (8.5"x11") on Portrait Mode. No such issue on Long Bond (8.5"x13") on Portrait mode.

For LO 5.3.4.2 on: macOS 10.12.6, osx10.10 (yosemite) and Windows10, no issue with Letter size on portrait mode being printed on landscape.

I just use LO 5.3.4.2 (macOS) until the problem is fixed on LO 5.4.1.2 (macOS)

Rally gravatar imageRally ( 2017-10-04 01:58:40 +0100 )edit

In our office system, LibreOffice 5.3.6 and 5.4.2 both are broken, under both MacOS 10.11.6 (El Capitan) and 10.12.6 (Sierra). I have posted a workaround below.

John Sidles gravatar imageJohn Sidles ( 2017-10-06 01:10:50 +0100 )edit

October 2017 and this is still a problem? This feature alone will prevent adoption of the program. I too have discovered a workaround. See below.

stveglines gravatar imagestveglines ( 2017-10-20 18:21:23 +0100 )edit

Just tried two more things that both worked. The easiest is to RESET PRINTERS which you can do in the system settings--go to "printers and scanners" and click "reset printer". It will delete all your printers and then you can add your printer again. The other fix that worked for me is changing the page width to 8.51 in "Format-->Page"

Libby24 gravatar imageLibby24 ( 2017-11-12 14:42:42 +0100 )edit

This whole discussion is just a load of crap. I downloaded LibreOffice to do some work. I have now spent over two hours to discover that the program won't print in landscape mode. It is useless to me.

mweeks10 gravatar imagemweeks10 ( 2017-12-28 19:51:55 +0100 )edit

Still a problem: MacOS 10.13.2, Libre Office 5.4, several different printers. Preview shows portrait mode, but print dialog shows landscape mode. Actually prints in landscape mode. WHY is this so hard to fix?

MikeT. gravatar imageMikeT. ( 2018-01-27 04:33:13 +0100 )edit

9 Answers

Sort by » oldest newest most voted
1

answered 2017-10-06 00:52:16 +0100

John Sidles gravatar image

updated 2017-10-06 01:08:29 +0100

MANY MANY PEOPLE have been troubled by this longstanding LibreOffice bug ... including my spouse at 2:00 am.

Here is yet another workaround, which I found by exhaustive testing.

The chief advantage of this workaround is that it requires NO changes to the document itself.

• MacOS: works for both 10.11.6 (El Capitan) and 10.12.6 (Sierra)

• LibreOffice: works for both 5.3.6 and 5.4.2

  1. Call up the print dialog for a "Letter" text document by the usual method, namely "File" -> "Print"

  2. If necessary, select the menu item "LibreOffice" (other choices in this menu include "Layout", etc.)

  3. Two tabs will be visible now: namely "LibreOffice Writer" and "More"; select the tab "More"

  4. Now a menu will be visible, whose choices include "All Pages".

  5. (Here's the "magic") select ANY menu item OTHER than "All Pages" ... then reselect "All Pages".

The net effect SHOULD be nil ... but instead, this sequence will trigger a refresh of the entire dialog box ... and the refreshed box will display a now-correct "Portrait" mode.

Problem solved ... but alas, this fix must be applied anew for each print step.

edit flag offensive delete link more

Comments

Thank you for sharing this finding; I've mentioned it on the issue page, so it may help Mac developer to find the problem.

Mike Kaganski gravatar imageMike Kaganski ( 2017-10-06 07:58:51 +0100 )edit

Please have a look on the amendments to my previous answer.

Lupp gravatar imageLupp ( 2017-10-06 12:41:51 +0100 )edit

Thank you for this workaround. Although it must be done for each print step, it does assume that the bug is in LibreOffice and, importantly, that the bug will soon be fixed. I appreciate Lupp's workaround but it presents the risk of having to reset templates back to their original, letter-size dimensions after a bug-fix for this issue drops into LibreOffice.

Thanks, Mike Kaganski, for a pointer to the bug report.

orestk gravatar imageorestk ( 2017-10-08 22:55:41 +0100 )edit

Having recently gotten the message from Microsoft that my old Office for Mac 2011 will no longer be supported, and finding that Office 2016 is bloated beyond all comprehension, I discovered LIbreOffice as a welcome alternative and ran into this bug. Thankfully, I found your workaround quite helpful, though not a preferred remedy. I am hoping that the developers will pay attention and can finally fix this problem.

Thanks,

Allan http://tinyurl.com/y7u27fhy

amkaplan gravatar imageamkaplan ( 2017-10-09 00:01:37 +0100 )edit

@orestk: This will depend on the frequency of your prints and the number of templates you are using.
Bug tdf#92190 (61 comments to date) was reported 2015-06-19 and is not yet assigned. May be long-lived.

Lupp gravatar imageLupp ( 2017-10-09 00:05:17 +0100 )edit

The magic button is Brochure. Turn it on, perform #5 above, then turn Brochure off. That's the magic.

stveglines gravatar imagestveglines ( 2017-10-20 18:25:54 +0100 )edit

There is no magic. There are a few workarounds, and to know one of them should not prohibit the study of the others already suggested. Depending on specific requirements different users may decide to prefer different ways.
This thread is rather bloated now. A bit more concise is this one on the same topic.

Lupp gravatar imageLupp ( 2017-10-20 23:42:13 +0100 )edit

I too have this same problem with OSX 10.13 running Libre Office version 5.3.6.1 printing to 8.5 x 11 inch paper. Playing with the above mentioned "Brochure" check box under -> Print -> More fixes it for me too. Yes it comes back every time you try to print.

miekb gravatar imagemiekb ( 2017-10-21 21:24:38 +0100 )edit

@miekb: This was already reported often. Did you also try the "Tiny-Change-of-Size-Workaround"?
Reports on this workaround, in specific concerning the changes for templates would be actually valuable for other visitors of this thread.

Lupp gravatar imageLupp ( 2017-10-21 21:55:29 +0100 )edit

Tried and tried - but it didn't work. I will work my way through the entire chain trying everything else but I do say that this has been very frustrating :-(

Wooby30 gravatar imageWooby30 ( 2018-01-27 18:08:25 +0100 )edit
0

answered 2017-04-28 16:06:59 +0100

bsikorski gravatar image

It is an issue with LibreOffice. Go to Format>Page and change the Format from Letter to A4

Go back to your print screen and all should be right in the world.

edit flag offensive delete link more

Comments

I don't have enuf points to upvote (bogus), but wanted to thank you for your answer. It's amazing that no matter how high-tech we get, it's always printing that drags us back to stone knives and bearskins mode.

p2 gravatar imagep2 ( 2017-08-07 17:46:23 +0100 )edit

Thank you for your advise! Changing the page format from Letter to A4 solved my printing problem. Now I can print in portrait mode instead of landscape.

Eveready gravatar imageEveready ( 2017-08-23 06:36:54 +0100 )edit

Add my thanks; I was seeing the problem on all documents. It would even do it saving as PDF. Selecting A4 format, clicking apply, then selecting back to "Letter" (so my printer wouldn't choke) fixed the problem.

tarlneustaedter gravatar imagetarlneustaedter ( 2017-09-12 05:15:24 +0100 )edit
0

answered 2016-10-01 21:43:38 +0100

Cynthia W. gravatar image

What if Format--Page is greyed out???

edit flag offensive delete link more

Comments

1

You surely understand that this is not a common behaviour of LibO 'Writer' which is used successfully by millions of people (among them myself) for printing in either page orientation, also mixed from the same document. Thus the problem you have must be due to specifics of your OS / printer / printer driver / LibO installation / your documents (settings protections / ...). Not knowing these specifics an answer might be impossible.

Lupp gravatar imageLupp ( 2016-10-01 21:57:02 +0100 )edit
1

Did you already try to (e.g.)
- reset your user profile?
- take your file to another computer (with a printer) and test there?
- completely uninstall your printer and reinstall it?
- look for an improved driver for your printer?
- completely uninstall (by means of your OS) LibO and reinstall the current version from scratch?
- print some newly created 'Writer' documents without much content?

Lupp gravatar imageLupp ( 2016-10-01 22:01:53 +0100 )edit

How nice for you Lupp. But the problem really is with your beloved LibreOffice. I downloaded an older version and the problem resolved itself.

CK from MD gravatar imageCK from MD ( 2017-10-02 17:19:32 +0100 )edit

Not in the mood for kidding.
There are many reports meanwhile seeing this problem very specifically related to LibO under some Mac OSX versions when using the outdated US paper sizes (Letter e.g.).
If you are on a different OS and use internationally standardised paper I don't have further advice.
(Decades ago were many issues related to cases where some parts of a software didn't know of updates creating mandatory indirections concerning attributes formerly set directly. A revival? )

Lupp gravatar imageLupp ( 2017-10-02 18:21:22 +0100 )edit

For me this permanently-stuck-in-Landscape print-problem occurs on two physically different Apple computers, running two different MacOS versions (namely 10.11.6 (El Capitan) and 10.12.6 (Sierra)), running two different LibreOffice versions (namely 5.3.6 and a fresh-install of 5.4.2). After a lot of experimentation, I found a workaround, that is posted below.

John Sidles gravatar imageJohn Sidles ( 2017-10-06 01:06:17 +0100 )edit

@John Sidles: The post you commented on here, wrongly created as an answer, addressed a different issue. Or did you ever find the sub-menu item 'Format' > 'Page...' disabled in relation to your issue?
(Your workaround may help nonetheless in this case.)

Lupp gravatar imageLupp ( 2017-10-06 12:54:55 +0100 )edit
0

answered 2018-03-14 19:52:17 +0100

MacBookPro Mid 2015, macOS 10.13.3, LibreOffice v5.4.5.1.

Opening a few existing Writer documents and a newly created one shows portrait as expected, so I'm not having a problem there.

Landscape issue still exists when opening existing spreadsheets, but newly created/saved spreadsheets are showing portrait properly. Tested using both .xlsx and .ods formats.

With this in mind, I 'Saved As...' a couple spreadsheets to see what would happen. Saving as .xlsx shows portrait, saving as .ods shows landscape, whether in the same or a different directory. Based on that, I'd say the issue now lies with existing .ods files created using version 5.2.7 (most likely). To support this claim, I copied & pasted the entire contents of an existing .ods into a newly created .ods...portrait!

In all my testing, I completely 'Quit' LibreOffice each time.

Hopefully this is a repeatable thing and the developers can find a fix! I'd rather not have all my users copy+paste a bunch of files or even re-save them in another format.

edit flag offensive delete link more
0

answered 2017-10-02 17:24:52 +0100

Same problem with LO 5.4.1. I downloaded Version 5.3.4.2 and it prints fine.

edit flag offensive delete link more
0

answered 2017-10-04 21:15:31 +0100

pkgoldberg@gmail.com gravatar image

Problem continues with LO Version: 5.3.6.1. Switching to A4 worked.

edit flag offensive delete link more

Comments

Suppose you were on 'Letter' (8.5 inch width by 11.0 inch height; 215.9 by 279.4 mm). A workaround I would suggest but cannot test myself is to omit the predefined setting for width and height and to replace them by slightly reduced values. Reduce each by a 1/100 of an "inch", and the printing to vertical pages should work.

The far better variant is, of course, to shift to the internationally standardized A4 if you have a chance to pull it through.

Lupp gravatar imageLupp ( 2017-10-05 00:33:00 +0100 )edit

Please regard the recent amandments to my previous answer.

Lupp gravatar imageLupp ( 2017-10-06 12:49:13 +0100 )edit

Thanks for this workaround. One problem I see is that once the bug particular to this problem is fixed, individuals might have to reset their templates back to the original dimensions.

orestk gravatar imageorestk ( 2017-10-08 22:48:18 +0100 )edit
0

answered 2017-10-20 18:17:58 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Another workaround is to bring up the printer page, then click on "more." click on Brochure. click on 2 sides, click Brochure off. The format has been corrected and you can print in Portrait. Unfortunately you have to do this every time you print anything.

edit flag offensive delete link more
0

answered 2016-09-07 11:35:15 +0100

Lupp gravatar image

updated 2017-10-06 12:46:07 +0100

If the page orientation under 'Format' > 'Page' is set correctly for each used page style, the issue should surely lie in the range of printer/printer driver. There are many different Epson printers and probably outdated printer drivers. To get help more likely, you should name your OS/version, the printer, and the actually used driver. On any system the same printer (hardware) can be installed with different drivers (software) under more than one names. One of the installations may be set as Standard ... Anotherone may be chosen for printing from LibO... A lot of fringes...

Edited regarding the course of the discussion here: Irrelevant parts striked out, explanation below added.

As I see it, it turned out that the issue is completely due to the operating system being OSX of some verion((s) on a Mac. In addition it seems most likely that it specifically is related to the outdated USA paper sizes. Unfortunately the OQ didn't name the OS even after being requested expressly.

In this thread and in others on the issue as well, the preferred suggested workaround was: Omit the usage of the predefined paper size and replace it by a slightly different 'User' defined size, say about 2/100 of an inch (2.54 cm) or 0.03 cm larger in one dimension. The change must be sufficient to persist over a save/reload cicle. (During my testing 0.02 cm e.g. were first accepted as a relevant change, but not properly saved then.) Please test to be sure.

Regarding the recent answer by @John Sidles:

As he stated himself, the steps need to be repeated in advance of each printout.
This may be error-prone and time-consuming.

I would prefer to apply the workaround described above to each template I have in use, in specific to the standard template of any document type if afflicted.

(Sorry, lacking a Mac I cannot test myself. But I watched the related threads, and feel rather sure that my advice is not just a blind man's talking about colors.)

edit flag offensive delete link more

Comments

It's not unique to MacOS or to letter size paper. I have the same problem with 9"x12" paper and Ubuntu 16.04. None of the work-arounds discussed in this thread make any difference. It will always print in landscape, even though the printer only supports portrait orientation. Version info Build ID: 1:5.1.6~rc2-0ubuntu1~xenial2 CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; Locale: en-US (en_US.UTF-8); Calc: group

Steve Brown gravatar imageSteve Brown ( 2018-02-16 14:59:52 +0100 )edit

If the problem is due to the OS why does Office and every other application print OK?

wrishel gravatar imagewrishel ( 2018-02-17 06:52:30 +0100 )edit
0

answered 2016-09-07 11:42:48 +0100

pierre-yves samyn gravatar image

Hi

Check also FilePrintOptions tab▸Use only paper size from printer preferences (ticked or unticked)

Regards

edit flag offensive delete link more

Comments

Thanks but I have tried that. :-(

Cynthia W. gravatar imageCynthia W. ( 2016-10-01 22:17:44 +0100 )edit
ennyme gravatar imageennyme ( 2018-08-04 11:37:13 +0100 )edit

The Epson printer drivers are necessary for the operating system to interact with the printer. Without a printer driver, your Epson printer is not able to perform printing job. If the printer drivers installed on your computer are of wrong type, obsolete, incompatible or corrupt, the printer does not work correctly. Therefore to rectify or fix the issue, please inspect the printer drivers carefully.

ennyme gravatar imageennyme ( 2018-08-04 11:37:28 +0100 )edit

Question Tools

5 followers

Stats

Asked: 2016-09-07 04:37:58 +0100

Seen: 13,713 times

Last updated: Mar 14 '18