Ask Your Question
0

Why cannot make text justified using styles

asked 2016-09-13 16:30:19 +0200

jasonlibreoffice gravatar image

I have applied font "Justified" setting to Default Style, Text Body, and whatever in the list of paragraph styles so that my text stands aligned as adjusted in equal lines, but still most of my body text, which has Default Style as shown in the Formatting toolbar.
image description

This is a text that I did not originate. I am just editing it, which has been originated in Microsoft Word. Currently other than justified text aligning, any other change that I make to the Default Style seems to be reflected on the text, but for justifying lines I have to manually apply it to every paragraph. Any ideas on how I can do this more easily in an automated way?
Just in case, I am working on an RTL Persian text with a Persian font, "B Lotus".

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2016-09-13 21:20:01 +0200

floris v gravatar image

Maybe right aligned text was set by direct formatting instead of per style in the original document. Direct formatting always overrides the settings in a style, so that would explain why changing the alignment in the style to justified isn't followed by the text. Select the text and press Ctrl+M to remove all direct formatting (careful: that will also remove italics applied to single words and the like).

edit flag offensive delete link more

Comments

Great working piece of information, thanks. I did not know about direct formatting beforehand.

jasonlibreoffice gravatar imagejasonlibreoffice ( 2016-09-14 08:01:37 +0200 )edit
1

answered 2016-09-13 18:19:48 +0200

petermau gravatar image

In the Paragraph style on the ORGANISER tab, there is an AutoUpdate option. If you select that each occurrence of the paragraph style will automatically follow that setting. Use it carefully. Also the NEXT STYLE option will select the next paragraph style when you select enter. The Alignment tab will allow you to right align the text.

If you are using Persian have you selected the CTL option? TOOLS > OPTIONS > LANGUAGE SETTINGS > LANGUAGES > CTL > PERSIAN

edit flag offensive delete link more

Comments

Thank you. But, checking Auto Update did not solve the problem :( Also, CTL is already set to Persian.

jasonlibreoffice gravatar imagejasonlibreoffice ( 2016-09-13 19:17:14 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-09-13 16:30:19 +0200

Seen: 526 times

Last updated: Sep 13 '16