Ask Your Question
0

Spell-checker Falsely Claims No Spelling Errors in DocumentA

asked 2016-09-17 06:27:09 +0200

Opcode gravatar image

I noticed a few days ago that none of the office suites on my computer (OpenOffice, LibreOffice and MS Office) would find misspelled words in my document. I test by intentionally misspelling a word, but the spell checker doesn't catch the misspellings. I've tried uninstalling and re-installing LibreOffice, but it still won't spell check the document, though it says it does so. I found that if I copy-and-paste the text of my document into an open, blank screen, then the automatic spell checker will flag spelling errors, but it won't flag misspellings if I open the document with the program. I originally created this document in OpenOffice, and it is an .odt file.

I uninstalled and re-installed LibreOffice. I also ran malware scanners on my system. I still cannot get the spell checkers to catch misspellings. Any ideas?

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
1

answered 2016-09-17 09:09:57 +0200

floris v gravatar image

When you start a new document from Windows Explorer (or file manager, that you use to browse your hard drive as opposed to the Internet) - right click in the files list, select New -> OpenDocument-text, you hit a bug in AOO and Libre - the new document doesn't properly set a language so spell checking doesn't work. That's why it probably also blocks spell checking in MS Office. The only workaround that I know is: start new documents with Libre or AOO open, from their menu or keyboard shortcuts.

edit flag offensive delete link more
0

answered 2017-12-10 07:37:19 +0200

Sha'Tara gravatar image

Even starting new docs as you suggest does not work. I use Ubuntu OS and I have the same problem: spell check returns no errors. I only find the errors if I copy and paste the document in a new Thunderbird email page. I've tried to find or reset dictionaries; tried to reset language between Canadian or US English - no results. No active spell check. Seems related to dictionaries not being accessed, or non-existent. How does one know if a dictionary is available?

edit flag offensive delete link more

Comments

For Ubuntu operating system rather than windoze you might try running the hunspell-en-gb installer from command line terminal: sudo apt-get install hunspell-en-gb ) which worked for me too running Libre Office Writer on Trisquel 8.0 LTS Flidas GNU/Linux (based on Ubuntu 16.04 LTS) and wishing for English(UK) spell check. When I exited and restarted Libre Office spell check was working correctly with propah UK English. Obviously one has to set the desired language for "All text" or whatever the appropriate selection under Tools/Language. I don't know what is the hunspell package for USA but I saw elsewhere someone referring to: hunspell-en-us

TrisquelUser gravatar imageTrisquelUser ( 2020-04-06 12:17:23 +0200 )edit
0

answered 2019-12-22 23:36:09 +0200

alan d gravatar image

Spell check does not work directly on copy & pasted text because the language is not set correctly,

Solution: Select all the pasted text; go to Tools -> Laguage -> For Selection. You probably find that the language indicated is something like {en}, change this to select the language you normally use, e.g. English, or Reset to Default Language and press Return. The pasted text will now show spelling errors.

edit flag offensive delete link more
0

answered 2017-12-10 09:59:15 +0200

gabix gravatar image
  1. Read this tutorial.
  2. If it does not help, ask a more specific question.
edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-09-17 06:27:09 +0200

Seen: 660 times

Last updated: Dec 22 '19