Ask Your Question
1

LibreOffice hangs on startup

asked 2016-09-20 08:00:57 +0200

HCI gravatar image

Recently, all my LibreOffice applications have started hanging on startup, while displaying the logo screen. App CPU usage is around 20% (I have an i7 chip with 4 cores, and 8 threads), according to Task Manager. No matter how long I wait, app startup does not complete and I end up having to stop LibreOffice application through Task Manager (the application icon does not appear on the task bar).

I've tried repairing, uninstalling and reinstalling LibreOffice, rebooting, renaming the AppData\Roaming\LibreOffice directory, but nothing works.

I'm using Windows 10 Pro 64-bit (the 1511 release, not the new 1607 anniversary update). I'm running LibreOffice x86_64 version 6.2.1.2.

Any suggestions?

edit retag flag offensive close merge delete

Comments

Please test disabling OpenGL, Menu/Tools/Options/LibreOffice/View

m.a.riosv gravatar imagem.a.riosv ( 2016-09-20 10:05:29 +0200 )edit

Thanks for your response. How do I disable OpenGL? I can't even start the application, so I can't get to the Options via the menu. Is it possible to do this from the command line?

HCI gravatar imageHCI ( 2016-09-20 16:21:33 +0200 )edit

In case anyone else makes the same suggestion, I don't believe that OpenGL is the problem here.

Of course, I could be wrong, but I've tried disabling OpenGL in registrymodifications.xcu and in the registry as a policy as well - and neither made the slightest difference.

HCI gravatar imageHCI ( 2016-09-22 22:57:57 +0200 )edit

Oops! Just noticed that I entered the LibreOffice version number incorrectly. For the record, I'm using LibreOffice x86_64 version 5.2.1.2. Sorry for any confusion!

HCI gravatar imageHCI ( 2016-09-28 20:29:49 +0200 )edit

Unfortunately, I don't yet have enough karma to edit my original post with updates. :-( I noticed that release 5.2.2.2 was released today, so I have that a try. No luck... Has anyone else had prolonged success with the 64-bit Windows version of LibreOffice 5.2.1 or 5.2.2? For former did work for me initially. Maybe it was a Windows update that broke it?

HCI gravatar imageHCI ( 2016-09-29 16:49:23 +0200 )edit

You may have more luck disabling OpenCL

Open a terminal and run: SAL_DISABLE_OPENCL=1 soffice and from the Tools -> Options -> OpenCL config area, disable use of OpenCL. Should start normally after that.

fluffynuts gravatar imagefluffynuts ( 2019-01-12 19:00:55 +0200 )edit

6 Answers

Sort by » oldest newest most voted
1

answered 2017-10-23 05:55:16 +0200

Babak_AB gravatar image

Hi. I have this problem in opensuse. I remove config file in path ./config/libreoffice

edit flag offensive delete link more

Comments

Perfect. That worked for me! Thanks!

the_watchmann gravatar imagethe_watchmann ( 2018-11-26 15:19:40 +0200 )edit
1

answered 2017-01-04 00:26:16 +0200

HCI gravatar image

Time for an update - and a workaround.

I just tried the latest 5.2.4.2 release - 64-bit - and I still have the same problem: every application hangs on startup after displaying the LibreOffice logo. (Just stating this once more for those who jump to conclusions: it's not an OpenGL issue.)

So, I tried the 32-bit version and guess what? It works without any problem! The workaround is to use 32-bit LibreOffice and avoid the 64-bit version for the time being - if you have this problem.

It seems to be too trivial to blame 64-bit code for the problem, but - as others have pointed out - the 32-bit version works while the 64-bit version hangs on application startup, on some machines at least. Just to recap, I did a number of clean installs of the 64-bit version and disabled OpenGL, so this is not a registry/configuration/OpenGL issue.

As this is an unsatisfactory conclusion, I have also raised bug report 105084:

edit flag offensive delete link more

Comments

This works... 32bit version works, 64bit version freezes. Unfortunately I can't upvote, needs 5 points.

tbn gravatar imagetbn ( 2017-06-18 11:24:44 +0200 )edit
1

answered 2016-09-23 15:22:15 +0200

ctariel gravatar image

I have the same problem on many computers at work. LibreOfiice hangs at startup, showing a white screen.

I did try all the thing you did (reset profile, add registry key, remove/reinstall, etc...) but nothing works. The only way to still use LibreOffice is to rollback to version 5.0.6.

Here is my opengl_device.log :

DriverVersion: 9.17.10.3190
DriverDate: 5-20-2013
DeviceID: PCI\VEN_8086&DEV_0102&SUBSYS_11B91734&REV_09
AdapterVendorID: 0x8086
AdapterDeviceID: 0x0102
AdapterSubsysID: 0x11b91734
DeviceKey: System\CurrentControlSet\Control\Video\{370D5BC5-5F1A-426B-950B-B7D60234B2B0}\0000
DeviceString: Intel(R) HD Graphics

And my dump.ini

OpenGLVendor=0x8086
OpenGLDevice=0x0102
OpenGLDriver=9.17.10.3190
UseOpenGL=false
edit flag offensive delete link more

Comments

One possible difference between what you're seeing and me: I just see the startup logo, and not a white screen. Otherwise, it's just as useless. I haven't tried downgrading yet, but that's definitely what I'm going to try next. Thanks for the suggestion!

HCI gravatar imageHCI ( 2016-09-29 16:43:26 +0200 )edit
0

answered 2016-09-20 22:55:34 +0200

floris v gravatar image

updated 2016-09-22 23:08:35 +0200

Reset your user profile. See https://wiki.documentfoundation.org/F... - important: rename the folder, don't delete it.

EDIT If that doesn't help, try a repair install. (Run the install file and choose repair install when that option is offered.)

EDIT 2 You might try to start Windows in safe mode and see if LibreOffice runs then to make sure there isn't some software conflict.

Maybe there's a bad registry entry. When you have uninstalled Libre, clean up the Windows Registry - find all instances of Libre that the uninstall didn't remove and delete them yourself. Then do a re-install.

If this answer helped you, please vote it with ✔ (here on the left). That will help other people with the same question.

edit flag offensive delete link more

Comments

Thanks. I did try resetting my profile, but no luck.

HCI gravatar imageHCI ( 2016-09-21 05:31:52 +0200 )edit

I already tried the repair install as well. No luck there either.

HCI gravatar imageHCI ( 2016-09-22 22:40:38 +0200 )edit

I'll give rebooting in Safe Mode a try - but that seems like a long-shot. I was using LibreOffice perfectly well until one day when nothing worked anymore, and I don't believe I've updated any drivers in-between it working and not working, but who knows?

I did clean the registry after uninstalling, removing all LibreOffice/OpenOffice references, then reinstalling, but that didn't do the trick. FWIW, I also cleaned out the filesystem as well. But it has to be something like that... :-(

HCI gravatar imageHCI ( 2016-09-22 23:15:09 +0200 )edit

It has to be something on your system, because it isn't crashing on most other computers. Any other system scans? hard disk running fine? I once had trouble with a program that sat on a bad sector on the hard disk.

floris v gravatar imagefloris v ( 2016-09-22 23:32:50 +0200 )edit

Sorry for the delay responding. I've checked the disk and there's no bad sectors.

Safe Mode didn't work, BTW.

HCI gravatar imageHCI ( 2016-09-28 20:24:48 +0200 )edit
0

answered 2016-09-21 00:11:21 +0200

m.a.riosv gravatar image

Please test replacing your registrymodifications.xcu that is in the root of the user profile, it has the OpenGL disable.

registrymodifications.ods

I have change to extension to ods to upload here, change the extension to xcu after download it.

edit flag offensive delete link more

Comments

Thanks for the file. I didn't replace my own file with the one you provided, because it included a number of settings that weren't applicable to my machine. But I did copy over the OpenGL related settings (ForceOpenGL and UseOpenGL). Unfortunately, that didn't do the trick. Do I need any others?

This is a particularly puzzling problem, because I've been using LibreOffice (and OpenOffice before that) for many years on this same laptop with no issues whatsoever. Now nothing works... :-(

HCI gravatar imageHCI ( 2016-09-21 05:07:28 +0200 )edit

FWIW, the AppData\Roaming\LibreOffice\4\crash directory contains a file called "dump.ini" that contains the following (each time I attempt to run, say, Writer, another identical block is added to the file):

OpenGLVendor=0x8086
OpenGLDevice=0x0126
OpenGLDriver=9.17.10.4229
UseOpenGL=false

That hasn't changed (I got the same output before adding the OpenGL settings you mentioned to my registrymodifications.xcu file), so I suspect that OpenGL isn't the problem.

HCI gravatar imageHCI ( 2016-09-21 05:12:47 +0200 )edit

There's also an AppData\Roaming\LibreOffice\4\cache\opengl_device.log file which contains the following:

DriverVersion: 9.17.10.4229
DriverDate: 5-27-2015
DeviceID: PCI\VEN_8086&DEV_0126&SUBSYS_04941028&REV_09
AdapterVendorID: 0x8086
AdapterDeviceID: 0x0126
AdapterSubsysID: 0x04941028
DeviceKey: System\CurrentControlSet\Control\Video\{469D7B61-9868-45D9-B476-E1C84DBD22BB}\0000
DeviceString: Intel(R) HD Graphics 3000

Hope that helps...

HCI gravatar imageHCI ( 2016-09-21 05:14:38 +0200 )edit
0

answered 2016-09-21 09:59:14 +0200

pierre-yves samyn gravatar image

Hi

May be you chan check the registry. See the attachment in tdf#93546

Regards

edit flag offensive delete link more

Comments

Thanks for your contribution. I added the specified registry entries - no luck.

These entries basically do the exact same thing that the answer from m.a.riosv suggested in the registrymodifications.xcu file, and they didn't work either.

I don't believe that this is an OpenGL-related issue.

HCI gravatar imageHCI ( 2016-09-22 22:48:58 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-09-20 08:00:57 +0200

Seen: 8,829 times

Last updated: Oct 23 '17