Ask Your Question
2

LibreOffice 5.2.1 & 5.1.5 crashing after upgrading to macOS Sierra (10.12)

asked 2016-09-23 16:23:30 +0200

Blanksheet gravatar image

updated 2016-10-14 09:25:32 +0200

David gravatar image
  • MacBook Pro late 2011
  • macOS Sierra

Upgraded the OS to macOS Sierra and LO 5.2.1 crashed on startup with message application quit unexpectedly.

LO worked before the upgrade and all other programs are working fine with the new OS.

I downgraded LO to 5.1.5 and have the same problem.

Tried:

Renaming the user folder to see if that would correct the problem, same results.

Installed LO 5.1.5 to see if that would resolve the issue. LO opened the first time I started the program and then crashed the next time with the above error message.

First part of the crash report from the 5.1.5 version installation:

Process:               soffice [831]
Path:                  /Applications/LibreOffice.app/Contents/MacOS/soffice
Identifier:            org.libreoffice.script
Version:               5.1.5002 (5.1.5002)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           soffice [831]
User ID:               501

Date/Time:             2016-09-21 10:44:45.709 -0400
OS Version:            Mac OS X 10.12 (16A323)
Report Version:        12
Anonymous UUID:        1243F49C-597B-4A22-4C0A-07CF2E4C5270

Time Awake Since Boot: 4700 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [0]

Any suggestion on how to fix this?

edit retag flag offensive close merge delete

Comments

Alex Thurgood gravatar imageAlex Thurgood ( 2016-09-23 16:39:30 +0200 )edit

Someone is trying to work on a fix, but it doesn't appear to be working yet.

Alex Thurgood gravatar imageAlex Thurgood ( 2016-09-23 16:43:23 +0200 )edit

Anyone have any information on when an update will be released to fix the macOS Sierra problems ?

Will a patch be released or do we have to wait for the next release cycle?

Blanksheet gravatar imageBlanksheet ( 2016-10-03 22:46:33 +0200 )edit

Open a Terminal-Session and start it with /Applications/LibreOffice.app/Contents/MacOS/soffice

works for me.

cd ~/Desktop ln -sf /Applications/LibreOffice.app/Contents/MacOS/soffice ./LibreOffice and as a workaround you should be able to start LO by double-click

Knut_HH gravatar imageKnut_HH ( 2016-11-14 00:06:32 +0200 )edit

12 Answers

Sort by » oldest newest most voted
1

answered 2016-10-13 10:50:11 +0200

jpc101 gravatar image

I think there mightbe a work around. I found it on the AOO forum (am I allowed to mention that on here?!!?! ;) ) https://forum.openoffice.org/en/forum...

So when LO is closed/quit, go to System Preferences > Displays > Color and choose 'Generic RGB Profile'. Then try opening LO. It works for me! The colors might look a bit washed out, depending on the monitor you've got, but hey if it works...

I've got two mac minis running external displays and only one had the problems - and that one was using a custom profile/calibration. I changed it to Generic RGB and it's ok! (the one without issues was already using Generic RGB)

I hope this might also be able to put people in the right direction to coding a proper fix...

edit flag offensive delete link more

Comments

This worked for me also.

RB gravatar imageRB ( 2016-10-13 16:27:53 +0200 )edit

So far this has also worked for me. 27" iMac AMD Radeon R9 M390 Graphics i5 core.

Pablito6318 gravatar imagePablito6318 ( 2016-10-14 14:51:11 +0200 )edit

Worked for me too! late-2015 iMac 27" 5K

CMinCR gravatar imageCMinCR ( 2016-10-16 20:52:06 +0200 )edit

This worked for me too! MacBookPro mid 2010. I chose "Generic RGB Profile" (german: "Allgemeines RB-Profil"), started LO without crash, changed Profle back to "Farb-LCD" (german for ~ "Color LCD"). Then stopped and restarted LO again w/o any more crashes!

t0r0X gravatar imaget0r0X ( 2016-10-17 10:59:06 +0200 )edit

Changing color profile to Generic RGB is working for me on my 2013 iMac (2.7 GHz Intel Core i5 processor, 8 GB 1600 MHz DDR3 memory), Intel Iris Pro 1536 MB graphics) with macOS Sierra 10.12.

vayaplaya gravatar imagevayaplaya ( 2016-10-19 12:12:45 +0200 )edit

NEEDED and worked with parallel install of 5.3.2 on MacBook OSX 10.10.5. BUT, it seems -- on subsequent login -- I need to change the colour profile back ... and it works. This is really odd, and unsettling. But it does work.

David gravatar imageDavid ( 2017-05-06 14:59:39 +0200 )edit
0

answered 2016-10-06 12:50:41 +0200

Peter A gravatar image

updated 2016-10-15 20:20:09 +0200

I have the same problem both the word processor and the spreadsheet crash when i try and move around a document. I have Open Office 4.0.1 and it is more stable. I also installed Open Office 4.1.2 and that crashes like Libre. Not sure that helps in identifying the problem.

I contacted Apple Care about a problem with full screen crashing the system. They took me through a procedure to clean up various folders in Library: caches....

Tha t fixed the full screen crash but it also fixed the Libre problem. Call AppleCare and ask them how to clean up caches etc.

edit flag offensive delete link more

Comments

This worked for me as well, I downgraded to version 4.0.3, on a macbook pro circa 2012 running mac OS Sierra.

gxclark gravatar imagegxclark ( 2016-10-19 22:04:36 +0200 )edit
0

answered 2016-11-04 13:57:38 +0200

DrieDeeDesign gravatar image

Same kind of problems here, with OSX Sierra. But damn that works, unchecking the auto pilot on video switching. Such a small detail causing so much annoyance. Thank you guys .... been without LO for over 2 weeks. Going back now to be a happy LO user. :-)

edit flag offensive delete link more
0

answered 2016-11-14 00:10:07 +0200

Knut_HH gravatar image

updated 2016-11-14 00:18:42 +0200

LO 5.2.3 works after install from the DMG-file, after rebooting the mac it crashes on start, still the graphicsmode issue:

Process:               soffice [1436]
Path:                  /Applications/LibreOffice.app/Contents/MacOS/soffice
Identifier:            org.libreoffice.script
Version:               5.2.3003 (5.2.3003)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           soffice [1436]
User ID:               501

Date/Time:             2016-11-14 00:11:03.763 +0100
OS Version:            Mac OS X 10.12.1 (16B2657)
Report Version:        12
Anonymous UUID:        F0032444-751F-346C-77BB-5309CA9FB436


Time Awake Since Boot: 2600 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb

But: Starting LO from a Terminal-Session works for me... /Applications/LibreOffice.app/Contents/MacOS/soffice

Maybe some issue in the Info.plist ?

edit flag offensive delete link more
0

answered 2016-11-17 04:15:48 +0200

It appears a recent development version (5.3.0.0.alpha1) may bring some significant improvements. I have yet to encounter any major issues running master~2016-11-17_00.29.28_LibreOfficeDev_5.3.0.0.alpha1_MacOS_x86-64 on macOS 10.12.1 (Build 16B2555) on a recent-issue iMac. See http://dev-builds.libreoffice.org/dai...

edit flag offensive delete link more
0

answered 2016-10-28 14:47:01 +0200

GBH gravatar image

5.2.3 RC1 fixes it. Works great

edit flag offensive delete link more

Comments

5.2.3 still crashes at first start, as 5.2.1 did:

Process:               soffice [12348]
Path:                  /Applications/LibreOffice.app/Contents/MacOS/soffice
Identifier:            org.libreoffice.script
Version:               5.2.3003 (5.2.3003)
[...]

2nd start worked fine. Never ending story.

t0r0X gravatar imaget0r0X ( 2016-11-07 11:52:44 +0200 )edit
0

answered 2016-09-29 16:40:28 +0200

Blanksheet gravatar image

updated 2016-10-14 09:23:42 +0200

David gravatar image

Tried the 5.2.2 released on 09/29/16. This release does not work with macOS Sierra

First few lines of the crash report.

Process:               soffice [678]
Path:                  /Applications/LibreOffice.app/Contents/MacOS/soffice
Identifier:            org.libreoffice.script
Version:               5.2.2002 (5.2.2002)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           soffice [678]
User ID:               501

Date/Time:             2016-09-29 10:31:45.086 -0400
OS Version:            Mac OS X 10.12 (16A323)
Report Version:        12
Anonymous UUID:        1243F49C-597B-4A22-4C0A-07CF2E4C5270


Time Awake Since Boot: 3700 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [0]

No use downloading this release if you are having this problem with LibreOffice.


Added 10/05/16

Tried the pre-release version 5.1.6.1. It is experiencing the same problem as prior releases for me.


Added 10/12/16

Removed all previous versions and installed the LO Dev build 5.2.3.1. As with previous releases the program opened the first time and then crashed the next time.

First few lines of the crash report.

Process:               soffice [708]
Path:                  /Applications/LibreOffice.app/Contents/MacOS/soffice
Identifier:            org.libreoffice.script
Version:               5.2.3001 (5.2.3001)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           soffice [708]
User ID:               501

Date/Time:             2016-10-12 16:51:08.964 -0400
OS Version:            Mac OS X 10.12 (16A323)
Report Version:        12
Anonymous UUID:        1243F49C-597B-4A22-4C0A-07CF2E4C5270

Sleep/Wake UUID:       79E46845-F44F-4451-8EA5-3E4CCF57CA25

Time Awake Since Boot: 5100 seconds
Time Since Wake:       3500 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [0]

I had seen reports that the graphic card switching was causing this crash.

When to Preferences>Energy Saver. With the power adapter button selected I unchecked “Automatic graphics switching”. This will cause the computer to always use the high-performance graphics.

After making this change LO will open without a problem. So for me the macOS Sierra problem has something to do with the graphic card and which one is being used. When the AMD Radeon HD 6770M is used all the time there is no problem with LO starting.

Hardware information

15” late 2011
macOS Sierra 10.12
Model Name: MacBook Pro
  Model Identifier: MacBookPro8,2
  Processor Name:   Intel Core i7
  Processor Speed:  2.4 GHz
  Number of Processors: 1
  Total Number of Cores:    4
  L2 Cache (per Core):  256 KB
  L3 Cache: 6 MB
  Memory:   8 GB
  Boot ROM Version: MBP81.0047.B2C
  SMC Version (system): 1.69f4

Graphics information:

AMD Radeon HD 6770M:

  Chipset Model:    AMD Radeon HD 6770M
  Type: GPU
  Bus:  PCIe
  PCIe Lane Width:  x8
  VRAM (Total): 1024 MB
  Vendor:   ATI (0x1002)
  Device ID:    0x6740
  Revision ID:  0x0000
  ROM Revision: 113-C0170L-573
  Automatic ...
(more)
edit flag offensive delete link more

Comments

Added 10/08/16 **

Downloaded and installed the current nightly build for mac found below.

http://dev-builds.libreoffice.org/dai...

This has corrected my problem with LibreOffice crashing at startup.

So far, have only tested Writer as that is the main application I use. Maybe other problems but so far all seems to be working with Writer. Does seem to be slow loading a document but it is a nightly build so some issues are expected.

Blanksheet gravatar imageBlanksheet ( 2016-10-08 20:07:50 +0200 )edit

I second Blanksheet's comments. I have yet to encounter issues running LibreOfficeDev (version 5.3.0.0) on macOS 10.12.1 (Build 16B2555) on a recent-issue iMac. See http://dev-builds.libreoffice.org/dai...

iscario-computer gravatar imageiscario-computer ( 2016-11-17 04:05:40 +0200 )edit

hi and thanks for this post. Turning off graphics card switching like you suggested worked for me without having to update LO (I'm running 5.1.3.2 on a mid 2010 MacBook Pro.

Luke Verling gravatar imageLuke Verling ( 2017-01-02 18:28:27 +0200 )edit
0

answered 2017-05-27 05:48:31 +0200

MarjaE gravatar image

I mostly use NeoOffice due to my photosensitivity, but it would help to be able to use LibreOffice for certain functions. It does find/replace better.

I can open 5.2.2 by reopening it after the first crash - there is no second crash.

I can't open 5.2.3 and above. I've tested up to 5.3.3.

I haven't been able to fix this by switching color handling, or by switching LibreOffice settings, or by using power management options that don't even exist on my computer.

edit flag offensive delete link more
0

answered 2017-11-13 21:55:26 +0200

DataCollector gravatar image

The installed version is LibreOffice 5.2.7.2 is working for me; however, macOS High Sierra - nothing works for me, had to go back and reinstall Time Machine backup of macOS Sierra.

edit flag offensive delete link more
0

answered 2016-10-30 00:43:50 +0200

THANK YOU! Turning off the video switching worked for me, I didn't want to mess with the color profile as I'm a heavy Photoshop user. (2011 MacBook Pro)

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

4 followers

Stats

Asked: 2016-09-23 16:23:30 +0200

Seen: 11,491 times

Last updated: Nov 13 '17