Ask Your Question

cannot set language for spell check

asked 2016-09-28 20:53:38 +0100

micksulley gravatar image

Running Version: in Mint 18. In Options > Language Settings > Languages I have User Interface = Default - English (USA) Locale setting = Default - English (UK) Default languages for Documents Western: Default - English (UK)

If I run spellcheck in any document it doesn't find any errors, but the Text Language is set to [None]. If I click hte drop down the only other option is English (USA), but I cannot select it, just goes back to [None]

This seems to be a problem in all modules.

How do I get spell checking to work?

edit retag flag offensive close merge delete


Just had the problem again with a new install and found this while searching - worth adding to this that it is necessary to install hunspell-en-gb as well.

micksulley gravatar imagemicksulley ( 2017-06-27 12:39:02 +0100 )edit

Thanks @micksulley - that fixed it for me: sudo apt-get install hunspell-en-gb. Only then could I set the test language to 'English (UK)' under Tools > Spelling and Grammar. Then at last all the the squiggly red lines appeared in my document:).

Nim44 gravatar imageNim44 ( 2017-12-30 12:04:00 +0100 )edit

2 Answers

Sort by » oldest newest most voted

answered 2016-09-28 21:54:07 +0100

Radish gravatar image

Do the following:

1) Open your document.

2) Keyboard CTRL+A. This should select all the text in the document.

3) Look at the very bottom of the LibreOffice Writer window - the grey bar at the bottom of the window. If you see an item there that reads "[None]" right-click on that item and select "English UK" - that will setup all the text in the document to be checked as English UK/English GB. If that is what you want, then save the document and you shouldn't have the same problem with it in the future.

Incidently if you downloaded the LibreOffice HelpPack English-GB and installed it to the system then to get it to work with LibreOffice you need, in Language Settings, to set the User Interface to English (UK). If you don't do this then when you click for help in LibreOffice then the help page will be opened in your browser i.e. you will be using online help (not offline).

edit flag offensive delete link more


That's direct formatting, and that's bad style, pun intended.

floris v gravatar imagefloris v ( 2016-09-28 21:56:28 +0100 )edit

Option 3 worked for me. Thanks Radish

sharat gravatar imagesharat ( 2018-02-27 01:58:11 +0100 )edit

answered 2016-09-28 21:27:57 +0100

floris v gravatar image

updated 2016-09-30 11:44:23 +0100

When you don't have a language assigned to the text of your document, assigning a language in the spell check dialog box isn't going to help you - the language listed there is the language assigned to the text being checked, and if no language was assigned, then the spelling won't be checked. Period.

Check out Tools - language settings - Languages and check that a language has been selected as default language for your documents, and make sure that the language listed there is actually installed. Also check that a language has been set in the Default paragraph style (and that language has to be installed of course). Note, thanks to Radish: you can select the language for text on the Font tab of the paragraph style dialog box.

A quick fix for most spell check problems is to reset your user profile. See - important: rename the folder, don't delete it.

If this answer helped you, please vote it with ✔ (here on the left). That will help other people with the same question.

edit flag offensive delete link more


"Also check that a language has been set in the Default paragraph style . . ."

Okay, Floris. But how do we do that? I've looked at my Default paragraph style settings and nowhere can I see any setting that allows assigning a language to the Default style. Where is the setting?

Radish gravatar imageRadish ( 2016-09-29 14:29:54 +0100 )edit

I found a setting in Paragraph Style: Default Style > Font (tab).

Radish gravatar imageRadish ( 2016-09-29 14:49:01 +0100 )edit
Login/Signup to Answer

Question Tools



Asked: 2016-09-28 20:53:38 +0100

Seen: 5,680 times

Last updated: Sep 30 '16