Ask Your Question
0

L.O.5.1.4.2 En spellcheck not working

asked 2016-09-29 20:16:59 +0200

BigAl gravatar image

Hi all,

I had been running Linux Mint 17.3 which came with LO v 5.0.3.2 Build ID: 1.0.5.3~rc2-Oubuntu1-trustu2 Locale: en-GB(en_GBUTF-8). My system HDD died so I installed a new one and took the opportunity to upgrade to Mint 18 which comes with LO. Version: 5.1.4.2 Build ID: 1:5.1.4-0ubuntu1. Locale: en-GB (en_GB.UTF-8)

The first writer document I opened is one I had been working one previously. Just a single page of text, no special formatting and no graphics. After adding a paragraph and making some other changes I ran spellcheck as I knew there were spelling mistakes (F7). It failed to find any errors.

One part of the text contained this badly spaced phrase "Ashebecamepartownerof ". Spellcheck should have picked that up.

So a new HDD. A new installation and the first document. Can anyone suggest what is wring please?

edit retag flag offensive close merge delete

Comments

You're running older version of LO. Since you're on Mint you can use https://launchpad.net/~libreoffice/+a... to stay up to date with LibreOffice Fresh releases. I'd try purging LibreOffice and its related packages, which should fix your issue. If it doesn't, you likely need to reset your user profile.

rautamiekka gravatar imagerautamiekka ( 2016-09-29 20:33:07 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2016-09-30 12:02:47 +0200

floris v gravatar image

If the text language in the document is English (US) and you only have a dictionary for English (GB), the spell checker won't find anything. Make sure that the correct dictionaries have been installed.

edit flag offensive delete link more
0

answered 2016-09-30 13:10:00 +0200

BigAl gravatar image

Thank you for the comments floris.

The text language in the document is UK English and the dictionary is UK English. Tha was one of the things I checked before posting. English UK is the default and was the default on my previous installation. I live in the UK so that is my natural choice.

rautamiekka, I am not at all sure what you mean. The version of LO is the one that comes with Mint and the version of Mint is the latest version.

As far as "... purging..." LO is concerned, I have no idea quite what you mean, or how to go about it or where I would find the related packages. I am just an ordinary computer user, not an expert. In any case I would have expected a default installation on a new hard disk to work out of the box and do not understand what has gone wrong. As far as I can see, everything else in Mint is working properly and there were no error messages when I installed it.

edit flag offensive delete link more

Comments

Your LibreOffice is oldish, not your Mint. I can't see how you misunderstood that. I'm looking for instructions how to add the PPA graphically since I don't have a Mint installed anywhere.

rautamiekka gravatar imagerautamiekka ( 2016-09-30 15:21:07 +0200 )edit

Also: NOT AN ANSWER ! DELETE AND REPLY TO THE CORRECT ANSWER !

rautamiekka gravatar imagerautamiekka ( 2016-09-30 15:21:49 +0200 )edit
0

answered 2017-03-12 01:24:59 +0200

TimC gravatar image

I had this problem and have found out the answer (at least for me).

Libreoffice will not warn you if there is no dictionary installed to match the language assigned to your document text. (Different to the interface language). It will also accept all words as correctly spelt if the dictionary is not installed. This has the effect that a completely garbled document will pass the spell check with no errors if your document language and the dictionaries available do not match.

To fix the problem, you need to install the correct language dictionary. Go to Tools->Extension Manager... and click on the "Get more extensions online..." link at the bottom of the window. If you are after English variants, the English Dictionaries extension is handy. When you have found the dictionary extension you want, download the oxt file.

GO back to the extension manager window and select the "Add..." button, navigate to your newly downloaded oxt file and open/install it. Then restart Libreoffice and your spell check should be much more successful. At least, mine was.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-09-29 20:16:59 +0200

Seen: 173 times

Last updated: Mar 12 '17