Ask Your Question
0

Spellchecking in LO Writer doesn't work on native files after fresh install of Linux Mint package

asked 2016-09-30 05:13:21 +0200

EdmundStD gravatar image

OS: Linux Mint 18 Sarah

LO Writer: Version: 5.1.4.2 Build ID: 1:5.1.4-0ubuntu1 CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; Locale: en-GB (en_AU.UTF-8)

Summary:

  • Spell checker does not work
  • Only one dictionary appears in the drop down menu
  • Cannot select that dictionary in the drop down menu
  • Dictionaries are installed in OS
  • Language settings are set in OS

Details:

Started using after fresh install (came with Linux package) but does not auto-correct spelling in native files. No settings have been changed or altered before use. Tested by entering intentionally incorrect spelling; does not underline in red, does not pick up when asking to manually spell-check.

Steps taken to attempt to fix problem:

/1/

Went to [Tools] -> [Spelling and Grammar] -> two windows open up immediately: First window is titled "Spelling". On top of that window is the second smaller window titled "Libre Office 5.1" which asks "continue checking at beginning of document [yes] or [no]".

The impression given is that the document has been checked and there is nothing misspelled. I know this to be factually incorrect: I have test errors in the text.

When I click "no" the smaller window disappears leaving the "Spelling" window remaining open. In this window the [Text Language] drop-down is blank. When I click on that drop down, there is one option only: [English USA]. When I click on that option, the drop down folds up but the selection is not selected: the [Text Language] remains blank. Simply put: I cannot select the one and only dictionary available in the list.

/2/

Still at the "Spelling" window. Went to [Options] and a new window appears titled "Options". In the top panel titled "User Define Dictionaries" all options are selected. In the lower panel titled "Options" the first three options are selected (i.e. check spelling and grammar as you type and check upper case words). Simply reclicking these does not fix the problem when attempting to spell-check again.

/3/

Went to OS [System Settings] -> [Language Settings].

  • Language is set to: English Australia
  • Region is set to: English Australia
  • System Local is set to: Apply System-Wide
  • Language support notes: 21 languages installed, including English USA, UK etc...

Additional anomalies:

When opening some (i.e. not all) DOCX files, the spell checker appears to work. However, as explained above, the spell checker does not work on any file created by this programme. None at all. This is extremely frustrating and I cannot find anything in the current forum threads that provides a solution. Any help would be greatly appreciated.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-09-30 11:45:01 +0200

floris v gravatar image
edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-09-30 05:13:21 +0200

Seen: 279 times

Last updated: Sep 30 '16