Ask Your Question
1

Base: Default date value shows up wrong in table -- any ideas?

asked 2016-10-04 01:30:55 +0100

stroy gravatar image

I entered default values for several items in the design view of a table. Integer values show up correctly in the table, but dates are wrong. I used the same date format in the design view mm/dd/yy in both the format entry and the default value entry.

edit retag flag offensive close merge delete

Comments

1

Please present a sample - what is the entry and what are you seeing in the table view?

Ratslinger gravatar imageRatslinger ( 2016-10-04 02:07:00 +0100 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2016-10-04 02:38:34 +0100

Ratslinger gravatar image

I believe there may be a bug and you should report it at Bugzilla. You can get around this (a bit awkwardly) by putting in a default date in the format of YYYY-MM-DD. Leave your format entry at mm/dd/yy. This causes no problems with the date. All dates are stored in the db as YYYY-MM-DD regardless of the view or entry.

If this answers your question please click on the ✔ (upper left area of answer).

edit flag offensive delete link more

Comments

Thanks again, Ratslinger. Your fix almost works -- after experimentation I discovered I had to enter a default date (in the format you recommend) but two days earlier than the value I wanted -- for some reason Base added two days to what I entered. Furthermore, if I went to another field in the design view, then checked back to the date field, another two days were added. Yes, this looks like a bug.

stroy gravatar imagestroy ( 2016-10-04 02:59:23 +0100 )edit

@stroy you may want to look at this post for further information regarding default dates.

Ratslinger gravatar imageRatslinger ( 2016-12-03 05:44:33 +0100 )edit
0

answered 2016-10-04 03:03:44 +0100

stroy gravatar image

This does indeed look like a bug. Ratslinger's recommended format works, except that I had to enter a default date two days earlier than the date I wanted, because for some reason Base added two days. Also, if I looked at another field in the design view, then went back to the date, another two days had been added. So this suggestion works, but in a roundabout way.

edit flag offensive delete link more

Comments

Actually (again I mentioned a bit awkward), if you enter the default date you want and save, no matter what is now displayed the original entry will occur. If you go back in and edit the table for ANY reason, you will again have to re-enter the date. These default dates are messed up.

Ratslinger gravatar imageRatslinger ( 2016-10-04 03:10:49 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-10-04 01:30:55 +0100

Seen: 100 times

Last updated: Oct 04 '16