Ask Your Question
0

Shift + Page Down/Up (Writer) [closed]

asked 2012-11-15 13:33:10 +0100

Oldbwl gravatar image

updated 2020-07-21 06:39:39 +0100

Alex Kemp gravatar image

In LO Writer, pressing the Shift Key + Page Down (or Up) should select a page length of the Document -and further presses of the Page Down/Up key should simply extend the selection. However, in my Version 3.6.2.2 on Ubuntu 12.10 the 1st page is selected but further presses of the P/Down/Up keys results in a deselection of all the text and the cursor moving a page length in the direction requested. The failure is not related to if the selection has to go across a new page or not.

The Key Bind is seems correct or the 1st event would not happen on the 1st key press.

I use this method frequently to remove several pages from texts and the only work round I have found is to use Shift + Down Arrow until the whole area to be removed is selected.

Is this a bug in the 3.6 series or a settings problem? I did try a removal and reinstall to no avail. I know this did not start until I recently upgraded from Ubuntu 12.04

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-19 02:36:21.552578

Comments

Try resetting the user profile?, reinstall does not delete the old one. wiki.documentfoundation.org/UserProfile

m.a.riosv gravatar imagem.a.riosv ( 2012-11-15 22:26:52 +0100 )edit

OK, tried that, no change, thanks for the suggestion though.

Oldbwl gravatar imageOldbwl ( 2012-11-15 22:31:51 +0100 )edit

3 Answers

Sort by » oldest newest most voted
2

answered 2012-12-11 12:26:56 +0100

Oldbwl gravatar image

I have now upgraded to LO 3.6.4 and the functionality appears to have been restored, many thank for the input

edit flag offensive delete link more
0

answered 2012-11-16 02:03:32 +0100

ROSt52 gravatar image

I made a test with Writer of LibO 3.5.7 on XP/SP3

Place cursor in a text Press shift+pageDown When I relaese the buttons, I hear a “camera shutter” sound. Moving the mouse down (without holding the left mouse key pressed!) selectes text until I - click the left mouse button again, then I hear the camera shutter sound again and the selection of text disappers - click pageDown again while still keeping shift key down, I hear the camera shutter sound again and the selections stays. I can move the cursor above the selction do right click an can work with the contect menu

Press shift+pageUp 15 lines of text above the cursor position are selected. Keeping shift key down and hit pageUp again cursor jumps up a page just as it would do without the shift button pressed.

I checked keyboard settings; they are: shift+pageUp selects previous page shift+pageDown selects next page

I conclude that this is a bug. Or did I miss something?

edit flag offensive delete link more

Comments

Well, your test confirms that on your system at least this is similar behaviour that I am experiencing. If no one else posts any differently I shall post the bug report shortly - Thanks

Oldbwl gravatar imageOldbwl ( 2012-11-16 15:07:16 +0100 )edit

Thanks already in advance for reporting a bug.

ROSt52 gravatar imageROSt52 ( 2012-11-16 15:32:15 +0100 )edit

No reason to file a bug - if your Desktop is grabbing the screenshot for itself (for taking screenshots apparently, as you hear the shutter), then LibreOffice doesn't even get notified of the keys.

Either remap the shortcuts in your Desktop Environment or within LibreOffice.

cloph gravatar imagecloph ( 2012-11-30 14:54:10 +0100 )edit
0

answered 2012-11-30 15:14:04 +0100

ROSt52 gravatar image

cloph, thanks for the explanation and the temporary workaround with remapping the shortcuts. However, I still regards this as a bug. The original setting of LibO got lost. I had during my test Writer fully open no part of my desktop was to be seen.

Oldbw, are you going ahead with the bug report? You would give me a hand.

edit flag offensive delete link more

Comments

that you see the desktop or not is irrelevant. It will still grab shortcuts. <alt>+<tab> will switch between applications no matter whether they are fullscreen or not for example.

If LibreOffice doesn't even get the keycombo (because it is taken by the Desktop), it doesn't have a chance

cloph gravatar imagecloph ( 2012-11-30 15:19:12 +0100 )edit

thanks for your explanations, I will make another test using LibO and something else to see if the key combination is taken by the desktop.

ROSt52 gravatar imageROSt52 ( 2012-11-30 15:43:47 +0100 )edit

OK I tested the same key combination with other applications and I can hear the shutter sound. This proofs your explanations. Do you have by any chance an idea how to stop this behavior? I assume it hast to do with the OS; I am using XP pro / SP3. I appreciate a hint very much.

ROSt52 gravatar imageROSt52 ( 2012-11-30 15:52:59 +0100 )edit

Question Tools

2 followers

Stats

Asked: 2012-11-15 13:33:10 +0100

Seen: 1,889 times

Last updated: Nov 30 '12