Ask Your Question
0

Controlling footnote style

asked 2016-10-10 00:21:04 +0200

WGroleau gravatar image

I have been using LibreOffice for a while; currently have 5.1.5.2.

My school has certain standards for formatting. I have modified styles and used "update to current selection" successfully. I then copy one document an delete the text to write the next document. This gets me the same re-defined styles, with two exceptions.

  1. I am not allowed to change the style of the footnote indicator.

  2. Every time I copy a document, the style of the footnote text has been changed back to the default. I have to change it again, and the change lasts until I save and close the document. Until today! Today, when I tried to "update to current selection," it instead changed the selection back to the default footnote style!

Is it a bug, or is there some special different way to handle footnotes? (If there is, it's not a bug, it's bad design.)

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2016-10-10 04:02:18 +0200

paul1149 gravatar image

Once you have the doc the way you want it, it would be better to save the doc as template, and then start subsequent docs from that template. You can delete all text before the save, so new docs will be blank. Alternatively, you can "Load Styles" from the original document, but the first way is more direct.

edit flag offensive delete link more

Comments

What I am doing is nearly the same: copy an old document, replace the text. But that is irrelevant to the question. The problems are (apparently) (1) changes to the footnote style are NOT saved; and (2) I can't find a way to change the ugly default style of the footnote number.

WGroleau gravatar imageWGroleau ( 2016-10-15 01:29:38 +0200 )edit
0

answered 2016-10-10 00:58:32 +0200

RGB-es gravatar image

Footnotes are controlled by three styles: one paragraph style for the actual text (called, appropriately "Footnote") and two character styles for the footnote indicator, the first one used to format the footnote "anchor" (the number you see on the text area) and called "Footnote anchor" and the other used on the footnote area and called "Footnote characters". Just open the styles and formatting editor (F11) and modify those styles according to your needs.

My advice: avoid updating styles "from selection" and always use the style editor, everything will be easier and more predictable ;)

edit flag offensive delete link more

Comments

OK, I will hunt for that footnote character. Didn't find it looking before. Character styles stored in a different menu than paragraph styles? And I'll check whether it will save the change that way. It's still either a bug or bad design that "from selection" changes are saved except when they are "footnote"

WGroleau gravatar imageWGroleau ( 2016-10-15 01:31:07 +0200 )edit

Character styles are listed on the second tab on the styles and formatting tool

RGB-es gravatar imageRGB-es ( 2016-10-15 14:37:27 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-10-10 00:21:04 +0200

Seen: 637 times

Last updated: Oct 10 '16