Ask Your Question
0

LibreOffice Extremely Slow in Mac OS Sierra

asked 2016-10-12 19:48:49 +0200

GBH gravatar image

None of the current versions of LibreOffice performs acceptably in Sierra. To do anything gets the Mac spinning ball. While things work eventually, it takes forever and is essentially non-usable as currently operating. By contrast, OpenOffice 4.1.2 and NeoOffice work great and are fast. I would like to stick with LibreOffice, but I hope these issues can be fixed.

edit retag flag offensive close merge delete

Comments

Please try resetting the user profile, sometimes solves strange issues. https://wiki.documentfoundation.org/U... Usually it's enough renaming/deleting the file "user/registrymodifications.xcu", it affects all the options in Menu/Tools/Options, and the files "user/basic/dialog.xlc" and "scrip.xlc" are overwritten, additionally custom colors in "user/config/standard.soc" are lost.

m.a.riosv gravatar imagem.a.riosv ( 2016-10-12 20:07:21 +0200 )edit

Resetting the profile didn't do it for me on Sierra (10.12) and LO 5.2.2. Cheers!

dnt2lo gravatar imagednt2lo ( 2016-10-12 22:24:22 +0200 )edit

Having your hardware config might help, if only to eliminate other potential known issues. Also, whether or not you have, or are attempting to acess your files over a network share. Otherwise, I can not confirm any particularly debilitating slowness, and I have LO52 running on Sierra with a Mac-min 2010 and a MBPro 2013. While the Mac mini is slow generally since the upgrade to Sierra, LO isn't noticeably even more slow than it was before the upgrade to 10.12. On the MBPro, performance is OK

Alex Thurgood gravatar imageAlex Thurgood ( 2016-10-13 17:48:23 +0200 )edit

Same here: clean install of Sierra and Libreoffice 5.2.2.2 on a Macbookpro 15 inch with 27 inch Mac screen. 2.7 Ghz 8 Gb memory. Reset user profile, no improvement. Libre office very very slow and spinning ball pretty much alll the time. Resetting to RGb profile also didn't help

remcol gravatar imageremcol ( 2016-10-20 14:27:32 +0200 )edit

I just downloaded libreoffice 5.2.4 on my mac and it is just unusable. Every time I try to open libreoffice it just hangs with "Verifying LibreOffice". It also slows my whole machine - I just almost can not do anything. I had 4.something before and it worked fine.

My mac is 2.9GHz with 8G memory.

uttams gravatar imageuttams ( 2017-01-06 00:52:38 +0200 )edit

Sad, but true. See my answer below from yesterday. You may need to try NeoOffice or OpenOffice until something changes.

GBH gravatar imageGBH ( 2017-01-06 17:05:32 +0200 )edit

I see the problem on a Macbook with a second screen, but not an IMac using just the internal screen. Maybe this relates to the Mac screen focus switching?

JHG gravatar imageJHG ( 2017-02-01 21:01:45 +0200 )edit

The behavior is the same whether I am using the MacBook Pro without an external monitor or with an external monitor. Also, we have a new iMac and it has the same problem.

GBH gravatar imageGBH ( 2017-02-17 16:07:07 +0200 )edit

How much memory do you have allocated? Menu> ToolsOptionsLibreOfficeMemory Try increasing it. Not sure it will fix issues, just something to look at. (How much memory do you have on your box? Is it system memory, or a SD card?) .. Can you look at your processes and see how much of the CPU LO is using? Is it mostly just waiting, or is it grinding on the CPU hard?

EasyTrieve gravatar imageEasyTrieve ( 2017-03-04 21:28:13 +0200 )edit

Same issue here. MBP 13" Late 2013. Mac OS Sierra 10.12.3. LO 5.3.1.2 build e80a0e0fd1875e1696614d24c32df0f95f03deb2.

Nicolas Rossi gravatar imageNicolas Rossi ( 2017-03-24 17:29:57 +0200 )edit

7 Answers

Sort by » oldest newest most voted
0

answered 2017-10-17 07:28:43 +0200

dottore gravatar image

updated 2017-10-17 07:30:18 +0200

If this is indeed a memory allocation problem (i.e. the default memory allocations are too small) then the developers should fix this by coming up with an algorithm that allocates memory in a way that gets good performance in most cases. Granted, it won't be easy, but it should be possible to look at the amount of memory in the system and then make an educated guess at the amount of memory that should be allocated.

FWIW I am currently trying the memory allocation adjustments recommended in an earlier post by Roger Paul and they seem to be helping. I'm just saying this is a lot to ask of average users.

I've been working with computers since the mid 60's and while I thought paging might be the cause of the problem, I had no idea that LO had default memory allocations set. If it weren't for this forum, I wouldn't have figured it out. If I couldn't figure it out, how is the average user going to figure it out?

edit flag offensive delete link more
0

answered 2017-10-15 04:25:31 +0200

I have this problem. I've found the workaround described here works for me.

Summary: Launch directly from executable within the application archive (/Applications/LibreOffice.app/Contents/MacOS/soffice for me).

edit flag offensive delete link more
0

answered 2017-09-26 18:24:33 +0200

Roger Paul gravatar image

updated 2017-09-26 21:20:26 +0200

Allocating more memory to LibreOffice fixed the performance issue for me on around one dozen Mac OS Sierra machines:

1) In the LibreOffice Menu go to LibreOffice > Preferences (on Windows and Linux go to Tools > Options)

2) In the Options dialogue window choose LibreOffice > Memory

3) Allocate more memory, for instance:

Image Cache:

Use for LibreOffice: 1'024 MB

Memory per object: 64.0 MB

Remove from memory after: 00:30

Cash for Inserted Objects:

Number of objects: 100

4) Of course the amount of memory you can allocate to LibreOffice is limited by the RAM available on your box. So you might wanna find your optimal configuration by testing different memory settings.

5) Mac OS Sierra needs significantly more RAM than older Mac OS versions. If your box has less than 8 GB RAM available then consider upgrading to 8 GB.

Hopefully this will work for you too!

edit flag offensive delete link more

Comments

@Roger Paul wrote: "1) In the LibreOffice Menu go to Tools > Options"

If you have a Mac system or if you know it you should know that there is nothing in Tools > Options. You have to go to LibreOffice > Preferences.

charlie.it gravatar imagecharlie.it ( 2017-09-26 18:59:03 +0200 )edit

You're right, the navigation path is platform-dependent:

On Mac OS Sierra go to Menu > LibreOffice > Preferences > LibreOffice > Memory

On Windows & Linux go to Menu > Tools > Options > LibreOffice > Memory

Roger Paul gravatar imageRoger Paul ( 2017-09-26 21:10:21 +0200 )edit

this is one of the best answers to a question I have ever seen. You are clear about what needs to be done and don't assume that the reader is a computer guru with special knowledge. thank you.

dottore gravatar imagedottore ( 2017-10-17 07:22:11 +0200 )edit
0

answered 2017-05-17 08:48:43 +0200

In my case, the sluggish speed was indeed related to an external monitor being attached and mirrored. After disconnecting the external monitor and restarting LO, it was drastically faster. LO 5.2.5.1, Mac OS X 10.10.5 .

edit flag offensive delete link more
0

answered 2017-03-20 22:39:32 +0200

Isolate your doc styles "applied styles". select each one 'modify..." and make sure you're not using proportionate scaling. Try 1 lines to test. Under line spacing part of indents and spacing. I just figured this out and had to share it!!!

edit flag offensive delete link more

Comments

Which versions of LO are you using? Your advice is not relevant to Mac OS 10.11.4 and LibreOffice 5.4.0.3

Fenton gravatar imageFenton ( 2017-08-06 22:03:58 +0200 )edit
0

answered 2017-06-06 21:19:24 +0200

lli gravatar image

ubiquitous spinning wheel with every function with LibreOffice 5.3.1.2 on Mac Sierra 10.12.5. Going back to Open Office which outperforms LO on speed.

edit flag offensive delete link more

Comments

I also found that the solution is to install Open Office which does not have the general slowness issue. I am running macOS Sierra 10.12.6 on a MacBook Pro Retina, 13-inch, Late 2013, 16GB of RAM, no external monitor.

I hope the LibreOffice team will address this problem as I would like to support them.

JacobRobbins gravatar imageJacobRobbins ( 2017-08-22 16:55:39 +0200 )edit
0

answered 2017-04-02 17:38:20 +0200

Hi there, Unfortunately what I see here is a typical unix person answer, asking to reset things, play with parameters, some shell commands...an so on.. The bottom line is. I just freshly installed Sierra on a formatted drive. Freshly installed a fresh copy of libreoffice.. UNWORKABLE.. period. I am not going to try things until you folks who are dealing with programming fix it. Do not suggest me a get around. İmplement it in a software fix. I am a cs professor 50 yrs old, 30yrs unix user

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

6 followers

Stats

Asked: 2016-10-12 19:48:49 +0200

Seen: 5,406 times

Last updated: Oct 17