Ask Your Question
0

Show chapter number in header without showing in heading [closed]

asked 2016-10-19 20:39:37 +0100

wwninja gravatar image

Hi,

I would like to have chapter numbers appear in my header, which I have successfully done by turning on outline numbering and inserting the chapter number field. But that also makes numbers appear in the headings within the text body. Is there a way to suppress or hide them in the headings?

I have tried giving the numbers a character style in the outline numbering dialog, and by modifying that style I can, for example, change the font color of the numbers in the headings without affecting the numbers in the header. But setting the "font effect" to hidden doesn't seem to work in this specific context (it does work if I apply the character style to other text -- bug?).

Thanks!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by wwninja
close date 2016-10-20 15:37:55.210736

3 Answers

Sort by » oldest newest most voted
0

answered 2016-10-20 08:07:00 +0100

pierre-yves samyn gravatar image

Hi

You can use the same color for the character style as for the background of the text (usually white) and you can hide the space taken up on the page with this outline numbering setting: numbering aligned right at 0, followed by nothing.

In the screenshot below I renumbered chapter 115 to show that the text is still aligned on the left margin:

screenshot

Regards

edit flag offensive delete link more
0

answered 2016-10-20 09:16:33 +0100

ajlittoz gravatar image

As you have noticed, there is no way to suppress the heading numbering without simultaneously suppressing the header numbering. Styling them white also still occupies some space before the title.

The trick is to put the number somewhere where it is not important whether it is wide or not.

I put the number inside the left margin (which should be wide enough to hold the largest chapter number -- this is fortunately always the case with a single number, even if 3-digit, with Heading 1).

Open Tools->Outline Numbering.... In Position tab:

  • set Numbering alignment to Right,
  • keep Aligned at to 0 (unfortunately can't be set to negative),
  • set the position of your title nearest to the left margin with:
    • Numbering followed by set to Tab stop
    • at 0.01cm (do not use 0 otherwise you will tab to the next default stop, probably ~1.25cm = 0.5")
    • Indent at 0.01cm (same value as previous in case your title needs more than one line)

Now, you can choose in Numbering tab a character style for the numbers to print them the same colour as the page background (usually white).

If this answers your question, please tick the check mark on the left. If you find it valuable, upvote it, karma permitting. Finally, if this is a satisfying answer, close your question for community benefit.

edit flag offensive delete link more
0

answered 2016-10-19 21:53:12 +0100

RGB-es gravatar image

Set the font colour on the character style used for the outline numbers as white: white characters over white background (the page) will make them invisible.

edit flag offensive delete link more

Comments

Yes, but they still take up space on the page. For my purposes this won't work--I need them effectively out of the document's flow. Thanks, though!

wwninja gravatar imagewwninja ( 2016-10-20 00:30:16 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2016-10-19 20:39:37 +0100

Seen: 233 times

Last updated: Oct 20 '16