Ask Your Question
0

Placing equals sign in front of function text in Calc corrupts the formula

asked 2016-10-27 15:53:28 +0200

jsheats gravatar image

In recent version (5.2.2.2) of Calc, if I enter the text of a function without the equals sign, e.g. FIND(“Ach Deposit”;A18) and then edit this cell by placing an = at the beginning, the result is FIND() and an Err:501. Typing exactly the same thing, i.e. =FIND("Ach Deposit";A18) gives a valid response (the number 1). This was not previously the case (I have used Find and Replace to remove the equals sign so that a formula could be copied elsewhere without changing the cell reference, and then putting the equals sign back), and makes no sense to me. What is wrong?

edit retag flag offensive close merge delete

Comments

Perhaps the problem is in quotes. While the formula is entered as text Calc applies AutoCorrect to quotes - https://help.libreoffice.org/5.2/Comm... And after conversion into the formula does not understand what kind of quotes. IMHO!

JohnSUN gravatar imageJohnSUN ( 2016-10-27 16:33:57 +0200 )edit

I tried to repeat this by removing the '=', then copied the cell and pasted to a new cell, then edit the new cell to add '=', but this was no problem. Also using 5.2.2.2. Perhaps I have different option set for autocorrect.

mark_t gravatar imagemark_t ( 2016-10-27 16:45:48 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2016-10-27 16:40:51 +0200

mark_t gravatar image

FIND(“Ach Deposit”;A18) and FIND("Ach Deposit";A18) are not exactly the same. The first has different characters for quote than the second.

If I copy the first into a calc cell then add the '=' I get an error 501.

If I copy the second into a calc cell and then add the '=' then it works.

You may have copied the first example from some source other than Calc, maybe a web page.

edit flag offensive delete link more

Comments

If the 'Replace double quote' (with "typographic" quotes as defined for the locale is chosen under 'Autocorrect options' LibO will do so when the supposed formula is entered as a text. Trying later to make it a formula will not revert this. "typographic" quotes, on the other hand, are not recognised inside formulae. Unfortunately the option cannot be set differently for 'Writer' and for 'Calc'. Due to a leading "=" the cell editor will know the intention and omit the replacement.

Lupp gravatar imageLupp ( 2016-10-27 21:19:15 +0200 )edit

Thank you to both; I was not sensitive to this difference.

jsheats gravatar imagejsheats ( 2016-11-27 21:19:34 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-10-27 15:53:28 +0200

Seen: 345 times

Last updated: Oct 27 '16