Ask Your Question
0

How to change text style and update all text with that style? [closed]

asked 2016-11-11 13:17:50 +0100

crobar gravatar image

updated 2020-10-24 23:32:14 +0100

Alex Kemp gravatar image

I have an existing LO Writer document with styles. I want to make a change to one of the styles and apply it to all existing text in the document with that style. As a specific example, I have a document with a style "Default Style" with font size 12 which I want to change to have font size 10 everywhere. How do I do this?

I have tried going to Styles => Edit Style and changing the font size in the dialog, then hitting Apply (then OK), but this only changed the style of the paragraph the cursor was in. How do I update all text with this style?

I'm using version 5.2.3.2 from the ppa on Ubuntu and in case it is relevant, this particular document was originally rtf format and I have now saved it as docx.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by floris v
close date 2017-12-21 22:07:13.583472

4 Answers

Sort by » oldest newest most voted
1

answered 2016-11-11 15:52:09 +0100

RGB-es gravatar image

It should work, but either the unchanging text uses a different style or has direct formatting applied on it.

Try selecting some of the unchanging text and press Ctrl-M to clean the direct formatting. If nothing happens, check that there is no character style applied to it (open the style and formatting editor with F11 and select the character style list). If nothing seems to work then please attach a sample document so we can see what's going on.

edit flag offensive delete link more
0

answered 2016-11-11 18:07:53 +0100

petermau gravatar image

updated 2016-11-11 18:09:23 +0100

On the Paragraph Style Menu > Organiser Tab there is an AUTOUPDATE option. Select that and the Font tab will be applied to all instances of that Paragraph. Deselect that option if you wish the changes to override only those in the current paragraph.

This option is only available for Paragraph and Frame styles.

edit flag offensive delete link more

Comments

Same problem is occurring in LO 6.1.3.2. Enabling Auto Update on the paragraph style does not make changes to the font style apply to all such paragraphs in the document.

Luke Kendall gravatar imageLuke Kendall ( 2018-12-20 08:44:44 +0100 )edit
0

answered 2017-12-21 20:19:19 +0100

seasoned_geek gravatar image

I have this exact same problem. Attached is a small sample document. You probably need to have the t1-cyrillic package installed to get the FreeTimes font. It's a DEB package available for most Debian based distributions. I used to write most of my books in FreeTimes, but, text/font rendering in LibreOffice has gotten pretty horrible, forcing a switch to Linux Libertine. No matter what I do the second paragraph of the preface stays stuck at FreeTimes.

Well, I can't upload the file because you need 3 points. THAT'S JUST DUCKY!

edit flag offensive delete link more
0

answered 2016-11-11 13:37:56 +0100

updated 2016-11-11 13:41:22 +0100

You have to cange the font size in page style if all pages uses it.

Or select all the text of the document and set character size to 10.

If my answer helped you, vote it with ✔ and with ∧ (here on the left)

edit flag offensive delete link more

Comments

I don't understand why a page style would specify a font, as that's a property of a paragraph style. Indeed, in LO 6.1.3.2 there is no panel in the Page Style panel that specifies any font.

Luke Kendall gravatar imageLuke Kendall ( 2018-12-20 08:46:32 +0100 )edit

Question Tools

2 followers

Stats

Asked: 2016-11-11 13:17:50 +0100

Seen: 5,006 times

Last updated: Dec 21 '17