Ask Your Question
0

[CALC] Match Function Bug

asked 2016-11-18 11:52:42 +0100

wquatan gravatar image

There seems to be a bug in the Match Function, especially when the cells to be checked contains a "(" ")" "[" "]"

I was ready to upload a screenshot of a test, but OMG ..... karma needed. How pity is the en.libreofficeforum.org shutdown ?


a   a   1

(a (a #N/A a) a) #N/A (a) (a) 1 [a [a #N/A a] a] 6 [a] [a] 1 @A @A 8 a@ a@ 9 a a #N/A a a a a 11 {a {a 12 a} a} 13 {a} {a} 14

    '=MATCH(Brow;$A:$A;0)
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-11-18 12:12:33 +0100

erAck gravatar image

It's not a bug, it's a feature ;-) Disable regular expressions under Tools - Options - Calc - Calculate, or escape regular expression meta characters in the search term.

edit flag offensive delete link more

Comments

Thanks, the disable did the job, but still I consider it very strange. The cells I compare are text-cells not formulae, so they should be used as such. The RegExp should only relate to formulae, not data (content)

wquatan gravatar imagewquatan ( 2016-11-18 12:24:24 +0100 )edit

@wquatan: "The RegExp should only relate to formulae, not data (content)."
Would you mind to tell us why? Content of type text and results of 'FormualResultType' text should be handled in the same way, IMO. They both answer TRUE if asked =ISTEXT(*This*). Many of my solutions working with RegEx relied on this behaviour.

Lupp gravatar imageLupp ( 2016-11-18 14:41:58 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-11-18 11:52:42 +0100

Seen: 126 times

Last updated: Nov 18 '16