Ask Your Question

Automatic Save not working! [closed]

asked 2016-11-22 23:06:47 +0200

JP007 gravatar image

updated 2020-09-02 10:12:19 +0200

Alex Kemp gravatar image

I've been working on a document for weeks. It automatically saves about every ten minutes. I also saved the document yesterday when I finished work. Today, my computer's mouse didn't come up and I re-booted the computer, the file I was working on, the latest copy is now 17th November (6 days old) - how can this happen? I've gone back through 'paths/backup' etc and nothing is there. I've checked back by searching key words/phrases - nothing. Any suggestions?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2020-09-28 20:34:03.082766


We used a computer company who remotely searched the entire system (which I had done, but certainly not to the level this guy could) - and he found the document, well 85-90% of it! Brilliant - pretty much found it all - just wondered what went wrong.....

JP007 gravatar imageJP007 ( 2016-11-24 07:34:41 +0200 )edit

4 Answers

Sort by » oldest newest most voted

answered 2017-03-30 06:39:15 +0200

EasyTrieve gravatar image
edit flag offensive delete link more

answered 2017-03-30 06:48:26 +0200

This kind of problem can only happen as a result of filesystem malfunction (either hardware problem, or OS FS driver failure).

The older files are deleted when new version is written. But the deletion of files only removes the file's entry from FS "table of contents". When file contents is not referenced anymore, it may be overwritten with any data. A journaling FS may fail in a way where an older copy of directory ToC is restored, thus "replacing" newer files with older (and at this point, possibly partially broken) versions.

edit flag offensive delete link more

answered 2016-11-22 23:45:49 +0200

floris v gravatar image

The "automatic save" really only saves recovery information for when Libre crashes. If you close Libre normally, it will remove that recovery information. You should always manually save your work every 30 minutes or so, and daily make a backup.

edit flag offensive delete link more

answered 2016-11-22 23:49:51 +0200

JP007 gravatar image

Thanks for answering, but the save key is hit (manually), at the very least, at the end of each day. That's why I cannot understand why it has reverted back to 6 days ago...

edit flag offensive delete link more


I remember that something like that came up at an openoffice forum years ago. I don't remember if there was a solution. I found one other discussion about an RTF file on Windows. Are you on Windows and do you save as .doc or .rtf?

floris v gravatar imagefloris v ( 2016-11-23 00:30:40 +0200 )edit

Thanks - on Windows 10 and it was an odt file. The odd thing is - (and this is worrying me as per 'operator error') is that the file is backed up on a thumb drive every day - except this time. However, it was definitely backed up on the 20th - but both the thumb drive and the computer's c drive have the last saved file as the 17th. This morning the mouse didn't work - computer rebooted, "reboot regardless" "yes" so that was an error, but why back to 6 days ago?

JP007 gravatar imageJP007 ( 2016-11-23 00:39:55 +0200 )edit

I've also trawled back the help/discussion files, but couldn't find anything exactly like this.

JP007 gravatar imageJP007 ( 2016-11-23 00:40:21 +0200 )edit

Question Tools

1 follower


Asked: 2016-11-22 23:06:47 +0200

Seen: 170 times

Last updated: Mar 30 '17