Ask Your Question
1

How do I get LibreOffice to always use a template whenever I start it up by clicking on a newly created document?

asked 2016-11-25 09:02:00 +0200

crow41798 gravatar image

I've created a template and set it as default in the "manage templates" section, but it will only automatically load the template when I select File > New on the context menu. If I create a new text document on my desktop I'd like to be able to just click on it and have it open LibreOffice with the default template already set. Is this possible?

Using LibreOffice 5.2.3

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2016-11-26 19:43:06 +0200

peterwt gravatar image

The template used when using right click on desktop > New > OpenDocument Text are in Program Files>LibreOffice(ver)>share>template>shellnew as soffice.odt. This is a document file not a template file.
You could try temporary renaming this file and copying your template file there renaming it to soffice.odt not .ott.
Try it and see if spellcheck works.

edit flag offensive delete link more

Comments

Thank you! It even seems like spellcheck works!

crow41798 gravatar imagecrow41798 ( 2016-11-28 20:44:55 +0200 )edit
0

answered 2016-11-25 09:43:22 +0200

floris v gravatar image

If I remember correctly, there's a bug in the utility to start new ODF files from the File Explorer. It loads a buggy default template and in such files spell checking doesn't work properly. As long as that bug isn't fixed, you'll have to start Libre and start new documents there.

edit flag offensive delete link more

Comments

Is this a bug that is reasonably expected to be fixed? Does it exist in previous versions?

crow41798 gravatar imagecrow41798 ( 2016-11-25 10:21:39 +0200 )edit

It has been around for a long time in OpenOffice, and therefore in Libre as well. I'm not a developer, so I don't know if or when it will be fixed. The developers probably aren't in a hurry because it doesn't stop you from working with it - starting new files within Libre isn't such a problem, just one or two mouse clicks more than starting from the desktop - so they'll say it's not very important.

floris v gravatar imagefloris v ( 2016-11-25 11:07:47 +0200 )edit
0

answered 2016-11-25 09:59:33 +0200

gabix gravatar image

Assuming by your question, you use Windows. You can create a BAT/CMD file containing a single command such as:

<full path to your template>\<template name>.ott

and put a shortcut to your desktop. Then simply double-click to start LO with a new document from the template.

edit flag offensive delete link more

Comments

Wouldn't work a shortcut to the template on the desktop just as well?

floris v gravatar imagefloris v ( 2016-11-25 10:01:31 +0200 )edit

For some reason, did not work to me (LO 5.0.2.1 on Windows 7), thus the above solution.

gabix gravatar imagegabix ( 2016-11-25 10:02:58 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-11-25 09:02:00 +0200

Seen: 558 times

Last updated: Nov 26 '16