Ask Your Question
1

Any attempt to open or edit a dialog crashes LO [closed]

asked 2016-12-06 09:32:45 +0100

owlbrudder gravatar image

I want to develop my own dialogs for a couple of applications, but any attempt to edit a dialog causes LO to crash within a few seconds. I have once been able to get as far as editing and twice got as far as being able to see the dialog in the edit window, but it was unresponsive.

I have removed all extensions previously added. I have uninstalled and reinstalled LO. I have tried running a single application (Base) with no other applications running. In all cases the result is the same.

In response to advice received on another thread, I tried running a fresh instance from the command line with the same result, but an error was reported:

`soffice -env:UserInstallation=file:///home/doug/new/

(soffice:8263): GLib-GObject-WARNING **: gsignal.c:3492: signal name 'selection_changed' is invalid for instance '0x560b45f08410' of type 'OOoAtkObjCompTxt'`

The error, though, appeared in the terminal before Base had even opened, so it may be unrelated.

Is there any way I can debug LO to find out what is wrong with my system? Clearly it must only be a problem here, because the use of dialogs generally in LO must be common, surely?

I have tried everything that seems obvious and followed all the help I have received, but the problem refuses to go away.

Kind regards, Doug

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by owlbrudder
close date 2016-12-08 08:07:45.731741

2 Answers

Sort by » oldest newest most voted
1

answered 2016-12-06 12:45:02 +0100

m.a.riosv gravatar image

Perhaps you can find help on this page: How to debug

edit flag offensive delete link more

Comments

Thank you m.a.riosv - that is what I have been looking for. I have already tried gdb, but it returned no error information shown above - in other words exactly the same as the message returned to the terminal when I run LO that way.

I will read the debugging page thoroughly to see if I can find something useful.

owlbrudder gravatar imageowlbrudder ( 2016-12-07 00:55:31 +0100 )edit

... information other than that shown above ...

owlbrudder gravatar imageowlbrudder ( 2016-12-07 00:56:40 +0100 )edit
1

Please report the issue with the backtrace on bugzilla. https://bugs.documentfoundation.org/

m.a.riosv gravatar imagem.a.riosv ( 2016-12-07 16:34:43 +0100 )edit

In cases such as this you might be able to find what is causing this behavior by starting with a freshly installed LO on a 2nd machine. If it doesn't crash there then you can add in your stuff, little by little, until it starts to crash. Normally when I break things down like this, I do a rsync between each test to keep a backup that I can roll back to to double check .. I know this is difficult and time consuming. Also it's possible it crashes on a fresh install, but this is unlikely I think.

EasyTrieve gravatar imageEasyTrieve ( 2016-12-07 19:26:42 +0100 )edit
1

answered 2016-12-08 08:06:17 +0100

owlbrudder gravatar image

The problem has nothing to do with LibreOffice: it is Fedora 25 at fault somehow. If I boot the Fedora 25 Live DVD and try to edit a macro, I get the same result - it crashes LO. If I boot the Fedora 24 Live DVD and try to edit a dialog, everything works fine!

I can't believe I am the only one using F25 and editing dialogs, so there is still a mystery to solve.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-12-06 09:32:45 +0100

Seen: 221 times

Last updated: Dec 08 '16