LibreOffice sometimes become busy and unresponsive in MacOS X

asked 2016-12-07 20:54:19 +0200

wirawan0 gravatar image

I have LibreOffice version 5.2 (see below for exact system specs) on a Macbook laptop. Generally I am happy with this software, but from time to time it would lock up, busy, unresponsive for a reason I don't understand. I also couldn't pinpoint certain action that triggers this behavior. I mainly refer to Writer, but it might also happen with other LibreOffice applications. The "top" command shows nearly 100% CPU utilization when this happens. Usually it will resolve, but it can take many seconds before it quits the unresponsive phase. Has anyone experienced this with the MacOS X version described below? The hardware has 8GB RAM and 5th generation (Broadwell) Intel i5 CPU, so it should be adequate for this job, even with web browser and a few other applications open.

My typical usage pattern is: I open 5-10 documents at the same time, mostly writer docs saved in ODT format. These are smallish documents (<100 kB each).

Info from "about LibreOffice" box:

Version: 5.2.3.3 Build ID: d54a8868f08a7b39642414cf2c8ef2f228f780cf CPU Threads: 4; OS Version: Mac OS X 10.11.6; UI Render: default; Locale: en-US (en.UTF-8); Calc: group

Thanks, Wirawan

edit retag flag offensive close merge delete

Comments

Please try resetting the user profile, sometimes solves strange issues. https://wiki.documentfoundation.org/U... Usually it's enough renaming/deleting the file "user/registrymodifications.xcu", it affects all the options in Menu/Tools/Options, and the files "user/basic/dialog.xlc" and "scrip.xlc" are overwritten, additionally custom colors in "user/config/standard.soc" are lost.

m.a.riosv gravatar imagem.a.riosv ( 2016-12-07 23:32:29 +0200 )edit

UPDATE: I found the action that almost always causes the busy CPU syndrome. One obvious action is resizing a window, or moving a window. Then the CPU usage of soffice becomes 100% for about 1 minute.

wirawan0 gravatar imagewirawan0 ( 2016-12-21 16:21:08 +0200 )edit

Have you tested with Menu/Tools/Options/LibreOffice/View - OpenGL, enable?

m.a.riosv gravatar imagem.a.riosv ( 2016-12-21 23:08:55 +0200 )edit

Reported as bug 105068 on LibreOffice bugzilla, here:

https://bugs.documentfoundation.org/s...

wirawan0 gravatar imagewirawan0 ( 2017-04-05 21:26:21 +0200 )edit