Ask Your Question
0

Autocorrect Apply does not work within custom style

asked 2016-12-11 09:05:14 +0200

slacker gravatar image

When I insert a document into a writer file and use 'Tools - Autocorrect - Apply' writer wants to change my custom styles. If I untick 'replace custom styles' in autocorrect options then no autocorrect is applied in those paragraphs at all.

What is the solution?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-12-11 09:43:43 +0200

floris v gravatar image

updated 2016-12-11 11:09:43 +0200

See https://help.libreoffice.org/Common/O... for a description of what Autocorrect (or rather Autoformat when it comes to replacing styles) actually does. I'm not a developer, so I don't know the reasons for this behavior, but it makes sense to me. Basically, the procedure assumes that you know what you're doing. You enter chapter headings as a sentence without a full stop, and subheadings as sentences without a full stop but with one or more tabs stops at the start, and the rest is plain text or indented text. You can also input numbered or hyphened lists. Then when you do Autoformat - Apply, it will replace the Default style by the styles that are indicated by your input. Now, if you took the trouble to make and apply some custom styles, you obviously don't want them to be replaced by Text body or anything else. When you untick that option, you basically tell Libre that you take full responsibility for that part of the document.

It's a bit different when you use autocorrect as you type, because the autocorrect will be in your face, you see what's happening, and you can revert what you don't want (Ctrl+Z). But automatic formatting of an entire document is completely different - you should really proofread it afterwards to check that everything was changed according to what you want.

See Tutorial List of inbuilt styles for more help on using the inbuilt styles.

edit flag offensive delete link more

Comments

Hmm I see. It's just that it autocorrects while typing just fine in those paragraphs.

So I guess the solution is to edit the default styles to my liking or go through the document and manually change apostrophes to single quotes and dashes to emdashes.

slacker gravatar imageslacker ( 2016-12-11 09:49:46 +0200 )edit

Yes, that's the general idea: you use the inbuilt styles, but you're free to modify them to your needs/wants. It's odd that straight quotes aren't replaced by curly ones in custom styles.

floris v gravatar imagefloris v ( 2016-12-11 10:08:59 +0200 )edit

If this answer helped you, please vote it with ✔ (here on the left). That will help other people with the same question.

floris v gravatar imagefloris v ( 2016-12-11 11:02:18 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-12-11 09:05:14 +0200

Seen: 129 times

Last updated: Dec 11 '16