How to set default fontsize without GUI

asked 2016-12-11 19:43:13 +0200

LO_USER12345 gravatar image

updated 2016-12-12 15:06:51 +0200

I am running Libreoffice in headless mode. Its running fine. I use LO Writer to export an HTML file as PDF. The HTML file is generated by MS Word. Everything works fine except that I have two issue.

Though the font in MS word is Arial 10 , Libreoffice displays it as Times New Roman 12. This is the default setting of LibreOffice. I was able to change the default font to Arial. I modified the below content of share/registry/main.xcd file installation directory.

<node oor:name="DefaultFonts">          <node oor:name="en" oor:op="replace">
                <prop oor:name="LATIN_TEXT" oor:type="xs:string" oor:op="replace">
                    <value>Arial;Liberation Serif;Thorndale AMT;Thorndale;Times New Roman;Tinos;Nimbus Roman No9 L;DejaVu Serif;Times;Lucida Serif;Lucida Bright;Timmons;New York;Serif</value>     </node>

I moved Arial to the first place for prop LATIN_TEXT. Tthe default font had become Arial. However I am not able to set Font size. I tried many methods. Infact, I replaced all occurrences of "12" in the main.xcd with "10". But there is no use. I don't want to use user template. I can't open LibreOffice because its installed on a linux server. Is there any way to set default font size?

The next issue is set default line spacing to SINGLE or proportional to 100%?

Thank you...

edit retag flag offensive close merge delete