Ask Your Question
1

My error has got LO opening too many file types

asked 2016-12-23 05:38:40 +0100

Penname gravatar image

I made a mistake in my Windows Control Panel, it was either Default Programs, or Associate a type of file with a program. I remember clicking on Libre office, and it asked me if I wanted to associate all files with it.

I thought it would only be the open document files & word files, excel files, etc. Mistake! Now it seems there are dozens that open with LO. For example, .jpg .bmp .cdr, to name just a few.

I thought if I uninstalled LO, they would go back to the original defaults, then could re-install LO. When I re-installed LO however, it re-took control of all those files again.

How can I get Windows to use the programs it was using before, then stop LO taking them all over again when I re-install it? It’s driving me crazy, even though it’s a mistake of my own making.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2016-12-23 05:46:59 +0100

Mike Kaganski gravatar image

updated 2016-12-23 05:47:57 +0100

Go to Default Programs control panel applet again; choose "Set defaults by App", and choose LibreOffice - then click "Select defaults for this app". There you see the types that are assigned to LibreOffice now (have checkmarks). You may uncheck them, take a note of which is the default for them (rightmost column), and then assign them to proper applications.

edit flag offensive delete link more

Comments

Thanks for the reply. I’m struggling in Control Panel. Running Windows 7 64bit.

In Control Panel I opted for “Set Your Default Programs”, then selected LO 5.2, and “Choose Defaults For This Program”. It displays file extensions on the left, then “Description” and “Current Default” on the right.

However, I cannot uncheck any of them, they’re all greyed out. I can select a particular complete line, but still not the extension checkbox. Have I followed the instruction incorrectly?

Penname gravatar imagePenname ( 2016-12-23 06:26:52 +0100 )edit

Oh, sorry. You cannot uncheck an already checked line there. I tested with empty lines, and so I didn't notice that.

Well, I can only advise you to write down the extensions that you want to re-assign from that window, and then use "standard programs for file types" mode to re-assign them.

Mike Kaganski gravatar imageMike Kaganski ( 2016-12-23 12:42:24 +0100 )edit

Thanks again for your help with this. I’ve just about got everything back to how it was originally.

In “Set your default programs”, I definitely shouldn’t click “Set this program as default” for Libre Office, because I now know that doing that makes it open absolutely all files types it possibly can, removing control from all the other programs that were associated with it.

Penname gravatar imagePenname ( 2016-12-23 14:53:25 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-12-23 05:38:40 +0100

Seen: 33 times

Last updated: Dec 23 '16