Ask Your Question
0

Office XP Infected my LibreOffice

asked 2016-12-26 01:12:32 +0200

Convert22 gravatar image

updated 2016-12-26 01:17:26 +0200

Sorry couldn't find a better title, LO was not really infected by Office XP, but I think it is all messed up because of it. I've been working with lot's of files that are using this old system...Office XP, and it includes the File Converter to make it compatible with other newer Microsoft Office Suites. I think it is called the Compatibility Pack or something to that effect. Now my LibreOffice has slowed down and keep getting these "~.lock" files(for lack of better term) when opening a file and then they quickly disappear. I keep all my important files on a USB, and now I get this .lock file thingy and lot's of performance loss. Here is the Crash Report: crashreport.libreoffice.org/stats/crash_details/488e487e-8420-4e49-b4a9-2246280c2a70

The only thing that makes sense to me is this, and not a lot of sense, to me at least: "EXCEPTION_ACCESS_VIOLATION_READ"

I'll also include this "LibreOffice Document Recovery" Screenshot. image description

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2016-12-26 10:04:18 +0200

floris v gravatar image

Reset your user profile. See https://wiki.documentfoundation.org/F... - important: rename the folder, don't delete it. If that doesn't help, run the install program again and choose Repair install when that option is offered.

If this answer helped you, please vote it with ✔ (here on the left). That will help other people with the same question.

edit flag offensive delete link more

Comments

Okay, found it. But there is also an option to "Reset" as suggested to find the actual "user" Pathway at that Wiki: Tools ▸ Options ▸ LibreOffice ▸ Paths > Reset at bottom Right. Is this not an option, if not I'll just Rename "user" as "user-old" I also Backed up the user profile to another folder offline. Thanks, Convert22

Convert22 gravatar imageConvert22 ( 2017-01-02 03:29:11 +0200 )edit

Okay, none of that fixed the issue? I just tried opening older .docx files that were created before I started having this issue, and still the same thing. Luckily I can still use everything as needed. Any further help would be very appreciated. Just to clarify, I renamed the user folder and the problem still existed, then Re-Installed LO and the problem is still there.

Convert22 gravatar imageConvert22 ( 2017-01-02 21:13:08 +0200 )edit

For some reason I now have all these Shortcut looking Icons on some of my System Folders, and, I can't get access to them. I don't need access to them at this time, but don't know what made these Folders like this? Wait, just realized, these look like LibreOffice Icons...and I've been having issues with LO Compatibility, sharing files with Microsoft Office XP, that is using the Compatibility Pack to read .docx etc. Here is a screenshot of what I'm seeing. link text

Convert22 gravatar imageConvert22 ( 2017-01-03 00:45:36 +0200 )edit

Another attempt at fixing my life LOL(because I create lot's of documents) I used REVO PRO to uninstall LibreOffice again. The problem is I still see lot's of LO Folders in my Profile, why is that? Here is what I see, I guess I should Delete these before reinstalling? http://i.imgur.com/3tYCRlp.png

Convert22 gravatar imageConvert22 ( 2017-01-03 01:38:48 +0200 )edit

Sorry for all the post's but need to fix this. Here is something else that was left over from the 32bit install, that may be causing me these issues also. It was when running CCleaner that I saw it, and CCleaner seemingly is asking me to Remove it from Registry, but I can't find it.
http://i.imgur.com/CYO4FYW.png

Convert22 gravatar imageConvert22 ( 2017-01-03 01:44:26 +0200 )edit

Uninstalling LibreOffice doesn't affect the user profile - that's why you can generally keep your settings when you upgrade LibreOffice - it uninstalls the current version, then installs the new version, without affecting the user profile at all.

floris v gravatar imagefloris v ( 2017-01-03 16:59:03 +0200 )edit

Thanks floris v, I have Deleted all folders in an un-experienced attempt to fix all of this. I'm really irritated at all of this and my inability to fix it. All still works but this .~lock file keeps coming up and slowing things down. Again, it is ".~lock" that is the problem, and I think it was from opening files created in Office XP Professional, mostly .doc, or maybe even .rtf. I was working on some customer computers, and they had MS Office XP Professional, with the Compatibility Pack.

Convert22 gravatar imageConvert22 ( 2017-01-05 16:14:52 +0200 )edit

I guess I'll try to file a bug report.

Convert22 gravatar imageConvert22 ( 2017-01-05 16:15:16 +0200 )edit

I see others have had this same problem, but each one is a little different than mine. I wonder what has caused this? I was really happy to have LO on my Windows Installs but it don't seem to be working out, so sad. Still works great on all my linux boxes!

Convert22 gravatar imageConvert22 ( 2017-01-07 01:41:49 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-12-26 01:12:32 +0200

Seen: 152 times

Last updated: Dec 26 '16