Ask Your Question
0

Web view margins

asked 2016-12-31 10:35:11 +0200

dcweaver01 gravatar image

updated 2016-12-31 13:52:51 +0200

When I enable the Web view in LibreOffice Writer, the text is right by the window edge.

I'd like to be able to add some margin between the window sides and the content.

I've tried changing the ruller sliders but the 'indent' slider only works for text.

While the other slider (filled grey area) just breaks the whole page and the document no longer re-flows when the window is resized. (seems bugged, although I don't know what the intention of that slider is)

Is there a reliable way to add some spacing between the window edge and the content in the web view?

edit retag flag offensive close merge delete

Comments

Another option is to use Normal view with 'Hide Whitespace' selected, from 'View' menu. (Ensure single-page view is also selected (otherwise 'Hide Whitespace' option will be greyed out.)

-

One downside is that, in this mode, grey lines still seem to show at the bottom of each page.

jonpatterns gravatar imagejonpatterns ( 2018-06-11 19:37:14 +0200 )edit

The grey lines at the bottom of the page can be removed via the dialogue box Tools>Options>LibreOffice>Application Colors

-

Untick 'Shadows' and make the Application background a pale color such as WhiteSmoke.

jonpatterns gravatar imagejonpatterns ( 2018-06-12 11:50:42 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2018-06-09 13:59:43 +0200

jonpatterns gravatar image

I would like to be able to add left 'padding' to the window in web-view mode too. At the moment I just position the window a bit to the right (not maximised).

edit flag offensive delete link more
0

answered 2018-06-09 14:29:10 +0200

ajlittoz gravatar image

updated 2018-06-11 20:26:31 +0200

There is no fundamental difference between document formatting and web formatting. You just customize the paragraph style for your block of text. Here are the vocabulary equivalences:

  • web margins (in Indents & Spacing tab)

    • top -> spacing, above paragraph
    • bottom ->spacing, below paragraph
    • left -> indent, before text
    • right -> indent, after text
  • web borders are paragraph borders (do you believe it?)

  • web padding translate only if there is also a paragraph border, otherwise ineffective (in Borders tab)

    • see Spacing to Contents for left, right, top and bottom

The sliders in the horizontal ruler will only change left and right margins. For the other parameters, you must proceed through paragraph style modification.

EDIT: answer to comments (2018-06-11)

I had not understood your need. I thought your were building a web document. In this mode, there is no notion of paper sheet. The document then occupies the full width of the window as per W3C specification.

I don't see your purpose with "continuous view". The draft may be written with a single paragraph style which will appear continuous, albeit there are page breaks. If your intent is to format this draft, then I personally prefer to see the complete result, including the appearance of margins. With Hide Whitespace, footnotes look very weird and are not immediately identified as footnotes.

With a wide screen, even of moderate size, you can try to display in Multiple-page view (the small icons near the zoom slider) so that several pages are simultaneously on the screen.

You then "style" your paragraphs and see the effect. Under Hide Whitespace, inter-paragraph spacing is not echoed at all, so you can't judge the adequation of your formatting.

I think your issue is in your workflow. If you could elaborate a bit, we could make better suggestions.

edit flag offensive delete link more

Comments

Thanks for the reply.

-

What I'm looking for is to be able to switch between a continuous document (Web view) and page format (Normal view). This enables me to quickly develop a draft into a document with page formatting.

-

Web view almost does this, but makes the document page about 28cm.

-

Hide whitespace almost does this, but draws a grey line at the page end.

-

Your suggestion would change t-he layout of the document in Normal view as well as Web view. As I'm looking to switch betwee

jonpatterns gravatar imagejonpatterns ( 2018-06-11 19:23:08 +0200 )edit

... between views this not an ideal solution.

-

Web view would work if you could set the page width for this mode (or sync it to the page width of Normal view).

See linked image, which hopefully gives an idea of what I'm talking about.

https://i.imgur.com/d2SuueF.jpg

jonpatterns gravatar imagejonpatterns ( 2018-06-11 19:31:08 +0200 )edit

Edit: actually Web view makes the page width to match the width of the LibreOffice window, which is like a Web page.

-

So I guess what I'm looking for is to be able to set a fixed or maximum page width in Web view (or set fixed or maximum page width to sync with Page view's page width).

jonpatterns gravatar imagejonpatterns ( 2018-06-11 19:45:41 +0200 )edit

I don't see your purpose with "continuous view". The draft may be written with a single paragraph style which will appear continuous, albeit there are page breaks.

-

My purpose is continuous view without page breaks. I'm not drafting the look of the document but also the content. Some parts of the document may just be bullet points. While I'm fleshing out the text and arranging ideas the page breaks get in the way - they split ideas which should be next to each other and generally aren't h

jonpatterns gravatar imagejonpatterns ( 2018-06-11 20:42:24 +0200 )edit

... aren't helpful to the flow.

jonpatterns gravatar imagejonpatterns ( 2018-06-11 20:42:39 +0200 )edit

I think your closest tool is single page view with Hide Whitespace. The grey lines showing page bounds are a minor annoyance. But, still, as a writer-editor, I don't see the advantage of "masking"the formatted end result. I tried to change line color, but it isn't under Tools>Options>LibreOffice>Application Colors.

ajlittoz gravatar imageajlittoz ( 2018-06-12 10:31:17 +0200 )edit

Everybody has different work flows.

-

I've managed to remove the grey lines via the dialogue box Tools>Options>LibreOffice>Application Colors

-

I unticked 'Shadows' and made the Application background White smoke.

Thanks for the help : -)

jonpatterns gravatar imagejonpatterns ( 2018-06-12 11:48:44 +0200 )edit

Thanks for the Shadows tip.

ajlittoz gravatar imageajlittoz ( 2018-06-12 12:08:48 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2016-12-31 10:35:11 +0200

Seen: 415 times

Last updated: Jun 11 '18