Ask Your Question
0

Tab after footnote when opening document in Word [closed]

asked 2012-12-01 13:58:19 +0100

Pierce Randall gravatar image

updated 2015-10-22 19:21:06 +0100

Alex Kemp gravatar image

Hi,

When I save a file with footnotes as a .doc or a .rtf file, and then I open that file in MS Word, I get these irritating tabs after the footnote reference number, but before the footnote text. That makes my footnotes look stupid.

You might be inclined to say, "Oh, well, full compatibility will never be reached," but I've actually had a lot of success getting every other compatibility issue cleared up. It's also not just a problem with the .doc format, because it's an issue in .rtf files too. (Although, of course, it may be a problem with MS Word, but we don't live in a perfect world where Microsoft is forced by market pressure or a sense of basic decency to put out an adequate product that's compatible with competitors.)

I'm thinking this footnote-tab thing is not really some dark piece of rogue code. It must be something about how LibreOffice records the character after the footnote anchor which throws off Word.

Thanks for your help!

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-10-22 19:21:25.634219

4 Answers

Sort by » oldest newest most voted
1

answered 2013-02-21 04:19:11 +0100

mahfiaz gravatar image

Please file an bug report and provide it with as much information about the issue as possible. It would even more help if you attach an example file and simple steps on how to expose the problem.

You could take a look at a similar bug report which I just reported, to get an idea on how to write a report: fdo#61201

If you have done so, please post a link here using the format "fdo#123456".

edit flag offensive delete link more
1

answered 2013-02-21 01:31:13 +0100

nustang70 gravatar image

B.Horvat, the tabbed footnote error only shows up once you've converted to .doc or .docx, then made changes, saved, closed, and reopened.

edit flag offensive delete link more
0

answered 2015-09-06 01:44:13 +0100

rpr gravatar image

This issue is also present in the current Writer 5.0.1. After some testing I've come to the following conclusion:

In the default installation Writer uses the Footnote style with hanging paragraph (the whole paragraph is indented by 0.6 cm except the first line). When you convert such an .odt document to .doc, Writer puts a tab character between the footnote mark and the footnote text, which looks fine in MS Word. (See test1 in the attachment.)

If you change the default Footnote style so that the paragraph is not indented and you convert such an .odt document to .doc, Writer still puts a tab character between the footnote mark and the footnote text, which significantly increases that space (the default tab position is about 1 cm). (See test2 in the attachment.)

As a workaround for the second case, you can change the Footnote style and add an explicit tab position at 0.5 cm. This does not change the appearance of the footnotes in Writer but in MS Word it will decrease the space between the footnote mark and the footnote text. (See test3 in the attachment.)

(I can't attach files to this post as I don't have enough points. So, you can get the test files here: https://goo.gl/EMcKq8 )

edit flag offensive delete link more
0

answered 2012-12-01 21:42:19 +0100

B.Horvat gravatar image

Hi,

I just tested, saved the document in .odf and .doc format. Then I open .doc in MS Word, footnotes looks indentical. When I change distance between number and text in style 'Footnote' and saved, again it was identical. Try check style 'Footnote'. Sorry, my English is bad.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-12-01 13:58:19 +0100

Seen: 745 times

Last updated: Feb 21 '13