Ask Your Question
0

Math formatting problem

asked 2017-01-11 03:42:34 +0200

jdpipe gravatar image

I am having some problems with poor-quality rendering of rather simple equations with LibreOffice Math.

For example, the equation

1 over {2 %sigma} + 1 over a + 1 over %sigma

renders very badly, with the denominators of the three different fractions not correctly lined up.

There are plenty of other examples like this -- they all stem from the use of Greek symbols used in expressions. This stems from the use of the OpenSymbol font by LibreOffice, which is a poor-quality font that doesn't contain the required 'font metrics' that allow the Greek symbols to be rendered correctly. Additionally, the default settings of LibreOffice have been poorly chosen such that Greek symbols appear in upright font, while other symbols (eg 'a' in the above) appear in italics, by default.

I am looking for a nice workaround that allows me to quickly fix my default LibreOffice installation so that it uses another Math font instead of OpenSymbol for all the greek letters, and renders them in italics instead of roman. Can anyone suggest something?

PS I have some bugs reported around this problem, if you could please add comments/"me too" to those bugs, it would help to get some attention for them: bug 104749, bug 67152, bug 48965

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2017-01-11 21:45:06 +0200

RGB-es gravatar image

Another workaround:

1 over {2 %sigma} + 1 over {{}a{}} + 1 over {{}%sigma{}}

This looks a bit better than the space.

edit flag offensive delete link more

Comments

looking for a workaround to change/fix the font, not to fool the layout engine. Basically I want to be rid of OpenSymbol.

jdpipe gravatar imagejdpipe ( 2017-08-27 12:56:59 +0200 )edit
0

answered 2017-01-11 08:20:25 +0200

ajlittoz gravatar image

My workaround is:

1 over {2 %sigma} + 1 over a + 1 over { " " %sigma }

The added " " forces the composition of an "expression" and the denominators line up. The added space is thin enough so that the division line is not too much enlarged and the dissymmetry does not become too visible.

I also tried 1 over { " " %sigma " " }, but the division line is now too large and the result is ugly.

The best solution would be of course to fix the bug.

edit flag offensive delete link more

Comments

Rather than a workaround to just render the equation, I was looking for a way to quickly change the font of all the affected OpenSymbol symbols to a better-behaved font like Liberation Serif.

jdpipe gravatar imagejdpipe ( 2017-03-15 07:26:44 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-01-11 03:42:34 +0200

Seen: 663 times

Last updated: Jan 11 '17