Ask Your Question
0

LibreOffice mixing / scrambling all letters on screen

asked 2017-01-27 22:21:04 +0100

daluan gravatar image

updated 2017-01-28 14:12:37 +0100

I've recently got a new computer with Windows 10 . After installing my fonts (TexGyre) and downloading LibreOffice I've opened the document I've been working. Two things got messed up:

a) the letters look in certain places all scrambled / messed up - but when I transfer the document to another computer everything looks fine. b) it seems the keyboard does not map to the correct letters. If I type the number '7', I see on the screen 'F'. If I switch to another program everything is normal. The computer is setup for English with US keyboard.

I've attached a small picture on how it looks like. Your suggestions are appreciated as I am at the end of ideas here.

I'm a new user so I cannot upload a graphic picture. I put a link here (small PNG file) so you can see what displays.

https://ln.sync.com/dl/fdc7aa4d0#8u2t...

Thanks. PS: I've changed the TexGyre font to regular Times Roman and the problem improved but did not go away.

edit retag flag offensive close merge delete

Comments

Can you share a sample file with the issue?

m.a.riosv gravatar imagem.a.riosv ( 2017-01-29 00:32:46 +0100 )edit

Thank you for your suggestion. I've added two samples from the same document but from different computers - a good one (desktop with windows 7) and a bad one (notebook with windows 10).

The link is here: https://ln.sync.com/dl/264d5e0d0#cngg...

daluan gravatar imagedaluan ( 2017-01-29 03:21:22 +0100 )edit

Daes it happen changing the Font for the style?, for me looks ok but I have not installed the 'TeXGireTermes' font. Or attach the file with the font embedded. Menu/File/Properties/Font.

m.a.riosv gravatar imagem.a.riosv ( 2017-01-29 21:31:09 +0100 )edit

Thank you m.a.riosv, I've done several tests following your suggestion. Sometimes it works, sometimes it doesn't. Nevertheless, I've managed to have both fonts in the same page. When I type "3" in one font (TexGyre) it display "e" instead but with the regular font it looks OK. Changing fonts, moving text to a new file as "unformatted textg" help and improves but does not solve all the problem.

daluan gravatar imagedaluan ( 2017-01-31 03:17:16 +0100 )edit

I gues, the test are always on the same machine?, verify if you really has the font installed.

m.a.riosv gravatar imagem.a.riosv ( 2017-01-31 12:57:27 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-01-31 14:40:34 +0100

JohnHa gravatar image

updated 2017-02-01 13:04:40 +0100

I've recently got a new computer with Windows 10

You have my sympathy.

Both .odt files look fine in AOO.

It is something on the PC - probably the fonts.

The AOO TestFonts AddOn at http://extensions.openoffice.org/en/p... is invaluable to check which fonts are being called for in a document, and which are missing and have therefore been substituted. Note that some fonts do not have a font file for, say, Italic; and in that case, when Italic is called for, Windows itself applies a slant to the font to simulate Italic.image description

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2017-01-27 22:21:04 +0100

Seen: 315 times

Last updated: Feb 01 '17