Ask Your Question
0

Change page size for entire document?

asked 2017-01-29 18:06:30 +0100

ShallowWharf gravatar image

updated 2017-01-29 18:12:07 +0100

I have a document within which I have pasted from other documents. When I go to format > page, the page size only effects the pasted document that I currently have my mouse cursor on. I have hundreds of documents like this that I want to format, and I would rather do it without having to go to format > page 6 times per document.

Is there a way to change the page size for the entire document? Selecting all also doesn't work, that only changes the size for the LAST pasted document selected.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2017-01-29 19:16:22 +0100

updated 2017-01-29 20:40:09 +0100

In LO, there's no manual overrides to page styles: everything about pages is only made with page styles. So, no removal of manual formatting may help.

Looks like each document that you paste, has its own page style that it brings with it. Its first paragraph defines that page style.

When you apply page style, it is applied to the pages run where there cursor blinks, even if there is selection (e.g. Select All). So, in usual case (after Ctrl+A), the cursor blinks on the last page, and so page style is applied to last pages run (starting from the last page break with page style). It isn't applied to all pages runs, unfortunately.

But you can e.g. select all, and clear the paragraph setting to define style. That will make the whole document one pages run.

Edit: OTOH, if the page styles in page breaks at the beginning of each document's part are paragraph's manual formatting, then the solution to clear manual formatting may help, because it will clear that setting.

edit flag offensive delete link more
0

answered 2017-01-29 18:29:09 +0100

LibreTraining gravatar image

Normally the Page Style controls the page size.

It appears the pages you are pasting have some manual overrides to the page size.

  • First do a Control + A to Select All

  • Then do a Control + M to remove manual formatting (style overrides)

That should do it.

Depending on what formatting you want to keep, you may want to consider using Paste Special instead of just pasting. That causes the pasted text to be un-formatted and causes it to take on the style of the surrounding text.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-01-29 18:06:30 +0100

Seen: 911 times

Last updated: Jan 29 '17