Ask Your Question
1

Installing help Deb

asked 2017-02-04 15:04:22 +0200

ezwebby gravatar image

updated 2017-02-04 15:25:50 +0200

ratrace gravatar image

Hi everyone. How come when I install the next version of libreoffice I always have to manually un-install the older one? In this day and age this seems a little silly considering most software today looks for and automatically un-installs previous versions. But what stumps me is I can never figure out how to install the help deb, every time. It says there is a dependency issue. Can you clue me in how to.... thanks

edit retag flag offensive close merge delete

Comments

I think there should be a question asked by the installer: Do you want to remove the currently installed version?

EasyTrieve gravatar imageEasyTrieve ( 2017-02-05 01:11:54 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2017-02-04 16:55:43 +0200

Ratslinger gravatar image

There is the possibility of having multiple versions on a system at one time for testing/comparison purposes. I've done it a while back but care must be taken. Problems can arise with things such as the user profile being shared. However, having a regular and a development version installed does not present this problem.

For the offline help, the file you use must be for your LO version (including whether 32 or 64 bit) and your UI language.

First extract the .deb file from the downloaded file. A double click on it usually bring up the Archive Manager to accomplish this. Then, depending upon your OS, double click the .deb file for Package Installer, or in a terminal window migrate to the extracted DEBS directory and run sudo dpkg -i *.deb.

edit flag offensive delete link more
0

answered 2017-02-05 00:02:25 +0200

ezwebby gravatar image

Well, I tried again and here is the result: andrew@andrew-dell-vostro-2420:~/Desktop$ sudo dpkg -i *.deb [sudo] password for andrew: Selecting previously unselected package libobasis5.3-en-gb-help. (Reading database ... 538575 files and directories currently installed.) Preparing to unpack libobasis5.3-en-gb-help_5.3.0.3-3_amd64.deb ... Unpacking libobasis5.3-en-gb-help (5.3.0.3-3) ... dpkg: dependency problems prevent configuration of libobasis5.3-en-gb-help: libobasis5.3-en-gb-help depends on libobasis5.3-en-gb (>= 5.3.0.3); however: Package libobasis5.3-en-gb is not installed. libobasis5.3-en-gb-help depends on libobasis5.3-en-gb (<= 5.3.0.3-3); however: Package libobasis5.3-en-gb is not installed.

dpkg: error processing package libobasis5.3-en-gb-help (--install): dependency problems - leaving unconfigured Errors were encountered while processing: libobasis5.3-en-gb-help

So maybe I have to un-install the last help package? But I dont know the name of it..

edit flag offensive delete link more

Comments

Don't know how you did the un-install on 5.2 (see this post). At this point, do another un-install, install v5.3 then install the help file. And just to be certain, you do have the LO en-gb version installed not en-US version right? Just noticed - What version was previously installed?

Ratslinger gravatar imageRatslinger ( 2017-02-05 01:24:20 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-02-04 15:04:22 +0200

Seen: 956 times

Last updated: Feb 05 '17