Ask Your Question

Thousands Separator Inconsistent [closed]

asked 2017-02-07 21:02:43 +0200

SirGawain gravatar image

updated 2020-09-23 20:42:17 +0200

Alex Kemp gravatar image

I am running LibreOffice v5.1.3.2 on Linux Mint 17.3, and my locale is en_ZA. The default currency format employing commas as thousands separators, negative signs after the currency symbol, and spaces between the symbol and digits is unacceptable to me. I can edit a user-defined cell format to effect the necessary changes, but the result of using a space as a thousands separator is inconsistent with that of the original comma, as illustrated below:


Observe that the comma thousands separator automatically repeats its task for every group of three digits before the decimal point. This is good, except that I'd like to replace the commas with spaces.

[$R]# ##0.00;-[$R]# ##0.00
     R 12.00
    R 123.00
   R1 234.00
R1234 567.00

A space thousands separator only works literally, in that it inserts a space before the first set of three digits, as defined by the hashes in the format code, and never again. Furthermore, the space is entered as long as there are three digits or fewer.

This is what I would LIKE to see, and any assistance achieving it would be greatly appreciated:

    R1 234.00
R1 234 567.00


edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-09-23 20:43:00.754258

1 Answer

Sort by » oldest newest most voted

answered 2017-02-07 21:31:02 +0200

updated 2017-02-07 21:37:36 +0200

LibreOffice uses thousand separator defined for chosen locale. You cannot redefine it in mask (any character that has no special meaning is output verbatim). You may, however, choose different locale for a cell range, or (preferably) for a cell style. If you choose Armenian, I suppose, it will provide you with the thousand and decimal separators you need.

Also, for default locale, setting system thousand separator to space may work for you.

edit flag offensive delete link more


It seems that only Armenian and Georgian locales support the "1 234 567.89" format..

vstepaniuk gravatar imagevstepaniuk ( 2018-03-19 14:42:06 +0200 )edit

Question Tools

1 follower


Asked: 2017-02-07 21:02:43 +0200

Seen: 1,335 times

Last updated: Feb 07 '17