createUnoService("com.sun.star.system.SimpleSystemMail") not working [closed]

asked 2017-02-08 05:51:03 +0100

owlbrudder gravatar image

In the documentation here, SimpleSystemMail is shown as a service in module com.sun.star.system.

When I execute the following line of code, nothing is returned:

objClient = createUnoService("com.sun.star.system.SimpleSystemMail")

Why is my code silently failing? "8-[

Any help would be appreciated. Cheers, Doug

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2020-09-23 20:47:01.260609

Comments

I think I read that these interface specifications were written before the actual code to implement it, and so the code might not actually exist or be a stub. I'm sure of that for OO (Open Office), and pretty sure of it for LO as most of LO is actually just a fork of OO. But it is beyond me at this point to look at the actual code, but perhaps someone else could look into that.

EasyTrieve gravatar imageEasyTrieve ( 2017-02-09 01:04:26 +0100 )edit

Thanks EasyTrieve - that sounds plausible, especially as SimpleCommandMail works fine.

Would that also be why calling objMessage.setOriginator("somebody@gmail.com") is ineffective? I want to send a message from a mail account which is not the default in Evolution, but the message always come up with my default account as the originator. For example, I have an account for myself and another for a club I belong to; my own account is the default and I want to send a message from my club account.

owlbrudder gravatar imageowlbrudder ( 2017-02-09 05:36:32 +0100 )edit

<shrug>, hope you figure it out, and if so pls report back here.

EasyTrieve gravatar imageEasyTrieve ( 2017-02-09 07:06:20 +0100 )edit