Ask Your Question
0

Writer: web layout is slow with large documents

asked 2017-02-17 18:11:42 +0200

Zauber Paracelsus gravatar image

updated 2017-02-17 18:44:14 +0200

I have a large game design document I've been writing up for the last year. At a standard letter page size, it is roughly 85 pages in length. I dislike having to break it up into discrete pages, so I have tried editing it in web layout. Unfortunately, performance is greatly reduced when I use web layout. The apparent framerate while scrolling appears to be in the single digits, and while editing the document things are equally as sluggish, with occasional freezeups lasting anywhere between 3-10 seconds.

Is there anything I can do on my end to alleviate this issue, without splitting the document up into smaller documents?

I have tried forcing libreoffice to run with the gtk2 and gtk3 toolkits, but neither have had any effect. I have tried disabling hardware acceleration, and that made no difference.

My system is running on 64bit Ubuntu 16.10 with the LXDE desktop, and my CPU is a 4ghz AMD FX-8350 octacore, and I have 16gb of DDR3-1866 memory (2x8gb dual channel).

EDIT: I dual-boot between Ubuntu and Windows 8.1. I just booted up onto my Windows drive, and I find that LibreOffice has the same issue. Additional info: My Ubuntu drive has LibreOffice version 5.2.2 installed, while my Windows drive has version 5.2.5 of LibreOffice.

edit retag flag offensive close merge delete

Comments

What are your memory settings in LibreOffice?

LibreTraining gravatar imageLibreTraining ( 2017-02-17 18:43:55 +0200 )edit

Under Linux, I have "Use for LibreOffice" set to 256mb and "Memory per object" set to 10mb. Under Windows, those are both at their default values of 128mb and 8mb respectively. Also, wouldn't it have been better to place that question as a comment rather than an answer that asks a question?

Zauber Paracelsus gravatar imageZauber Paracelsus ( 2017-02-17 18:55:05 +0200 )edit

Okay, for some reason I can no longer edit my original question. I was going to add that this issue is seemingly worse under Apache OpenOffice.org, where it freezes for a couple minutes after turning on web layout, and then after that the framerate is less choppy by the random freeze-ups are longer.

Zauber Paracelsus gravatar imageZauber Paracelsus ( 2017-02-17 19:00:59 +0200 )edit

You're right - moved to a comment.

I have a 471 page document with 551 images in LibreOffice 5.3 on Windows 7 - and in regular edit mode it scrolls pretty fast. And this laptop is no where near the specs of your computer.

Just changed to Web view and it took 3-4 minutes to respond and display, then again showed Not-Responding, and then when it came back scrolling is very slow with additional lock-ups. Back to Normal view - fast again.

Memory settings 200MB, 50MB per object, 20 objects.

LibreTraining gravatar imageLibreTraining ( 2017-02-17 19:18:42 +0200 )edit

I set 50MB per object to deal with some large images. Once an image is uncompressed in memory it can easily be 30 to 50 MB.

LibreTraining gravatar imageLibreTraining ( 2017-02-17 19:23:00 +0200 )edit

If you want to view your document with less wasted screen real estate try Hide Whitespace.

View > Hide Whitespace (Ctrl +Alt + H)

Still scrolls fast for me.

LibreTraining gravatar imageLibreTraining ( 2017-02-17 19:27:02 +0200 )edit

Hiding whitespace accomplishes most of what I wanted. One issue though, is that (at least on Windows with LibreOffice 2.2.5) is that if I turn Hide Whitespace on and then off, then the window completely deadlocks and has to be force-killed. Will see if this occurs on Ubuntu when I'm done updating stuff on Windows.

Zauber Paracelsus gravatar imageZauber Paracelsus ( 2017-02-17 19:33:50 +0200 )edit

I have also added keyboard shortcuts for all the Zoom Levels.

Optimal view (Ctrl+Alt+O) - maximizes the view to show just the part of the page inside the margins.

So that combined with Hide Whitespace would give you essentially what you want - just the content.

LibreTraining gravatar imageLibreTraining ( 2017-02-17 20:05:44 +0200 )edit

Okay, thanks. Also, the freezing issue with turning off Hide Whitespace seems to occur on Ubuntu as well as Windows. However, it seems to be specific to my design document, or perhaps a specific element within my document.

Zauber Paracelsus gravatar imageZauber Paracelsus ( 2017-02-17 20:13:58 +0200 )edit

The freezing problem with Hide Whitespace has seemingly vanished after I took out nearly two dozen page breaks in the document. Also, be sure to add your solution as an answer

Zauber Paracelsus gravatar imageZauber Paracelsus ( 2017-02-17 21:14:46 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-02-19 01:36:19 +0200

LibreTraining gravatar image

I know there are some recommendations around to use the Web view to see just the content without margins or page gaps, but I think Web view essentially makes your document one very long page.

While this makes sense when making actual web pages which are relatively small, it appears to cause performance issues with long documents.

If you want to view your document with less wasted screen real estate try Hide Whitespace.

View > Hide Whitespace (Ctrl +Alt + H)

That eliminates the vertical space (margins) between pages

I have added keyboard shortcuts for all the Zoom Levels; makes it easy to change the view.

image description

Optimal view (Ctrl + Alt + O) - maximizes the view to show just the part of the page inside the margins.

So that combined with Hide Whitespace would give you essentially what you want to see - just the content.

edit flag offensive delete link more

Comments

Thanks for the help. The only flaw with this is that the setting appears to be tied to the session rather than the installation or the document, so I have to turn it back on each time I start up Writer. But, that's only a minor issue.

Zauber Paracelsus gravatar imageZauber Paracelsus ( 2017-02-20 17:21:40 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-02-17 18:11:42 +0200

Seen: 387 times

Last updated: Feb 19 '17