Ask Your Question
0

Option to embed images in generated html file

asked 2017-02-19 14:23:56 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I just had to revert back to an older version of LibreOffice because apparently what I saw as a "feature" was actually considered to be a bug by everyone else.

Now when I save an .odt file as .html, the images are saved as links. I want to embed them, the way they used to be. I've searched all the menus and this forum and cannot find an option for this. I thought that "break link" under the edit menu would do it, but it doesn't.

What else?

edit retag flag offensive close merge delete

Comments

HTML files are plain text files. The only way I can think of to embed an image is to encode it like some small images in CSS.

Please explain what you are trying to replicate in the previous version.

And what is the previous version of LO you are going back to? so I can test

LibreTraining gravatar imageLibreTraining ( 2017-02-19 16:28:44 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2018-05-15 15:39:42 +0200

Patrice gravatar image

Hello, I have the same problem with version 5.4.5.1 you cannot embed image anymore into a html file, which for certain application make your project difficult to maintain. Is there a way to have this possibility with a plugin? Thank you Patrice

edit flag offensive delete link more
0

answered 2017-02-19 21:22:29 +0200

updated 2017-03-15 18:00:02 +0200

https://bugs.documentfoundation.org/s...

You may use command line to embed images:

soffice --convert-to html:HTML:EmbedImages file.odt
edit flag offensive delete link more
0

answered 2017-02-19 21:47:57 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I reverted to version 5.1.6.2 and it "works" as I was used to. After reading bug reports (including the one pointed to in this question's current answer), I understand that most folks did not like it "working" that way and it was changed in more recent versions. That would be fine, except I would like the option for it to work as before:

First, I'm running Windows 7. In Writer, after editing my .odt file, I use "file" --> "save as" --> .html. In 5.1.6.2, Writer creates one .html file in which all the pictures are embedded. The newer versions of Writer create one .html file with gobs of .jpg files with long names with long strings of numbers in them (one per picture in the document). Yeah, sure I can zip the whole mess up and send it to our webmaster, but he has grown to prefer the One File Solution!

I thought that maybe using "break links" under the "edit" menu in the newest Writer version might embed those images. It does indeed break the links, but the images are not embedded. Instead, there's a blank box where the image should be.

edit flag offensive delete link more

Comments

The Oliver's patch made it comparatively easy (in code) to select either embedded or linked variant. You may want to file a feature request for an option, with a link to the mentioned bug report as See Also.

Mike Kaganski gravatar imageMike Kaganski ( 2017-02-19 21:51:57 +0200 )edit

Oh, and the way I insert images into my .odt file, is to use "insert" --> "image" .

gigi gravatar imagegigi ( 2017-02-19 21:54:44 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-02-19 14:23:56 +0200

Seen: 1,800 times

Last updated: May 15 '18