Ask Your Question
0

How to increase the screen font size in Base?

asked 2017-03-02 04:33:24 +0200

How can I increase the screen font size in Base? I've read some of the other posts asking to increase font size but none of those seem to work (CTRL-[, for example).

I'm talking about the screen size while viewing tables, records, etc, not printing reports.

I'm using LO Version: 5.2.5.1, under Linux, using i3wm tiling window manager.

Thanks!

edit retag flag offensive close merge delete

Comments

The sad truth about using less common things, like i3 is that others don't know what they are. I am also red-faced, in that I didn't even know what a tiling windows manager was, though I had used one a number of times over the years, it just wasn't called that back then. I suggest you update the title of your question to reference i3, as this is not a generic question about screen font size, but rather a question about that as it relates to using i3.

EasyTrieve gravatar imageEasyTrieve ( 2017-03-03 17:15:35 +0200 )edit

I'm surprised you say that, since i3 seems to have nothing to do with the need or solution to increase the font size when viewing tables. As far as I can tell, the same situation exists for the Windows version of LO and Base. So why is this is not a generic question about screen font size when using tables? I only mentioned that I was using i3 in the case it might possibly have had an impact on the solution, but again, it seems not to have.

keithostertag gravatar imagekeithostertag ( 2017-03-03 19:51:57 +0200 )edit

@keithostertag, ok. Out of curiosity, I thought I read that i3 windows were mostly or completely non-overlapping, is that right?

EasyTrieve gravatar imageEasyTrieve ( 2017-03-04 19:50:43 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2017-03-02 04:49:31 +0200

EasyTrieve gravatar image

updated 2017-03-07 07:25:20 +0200

WARNING: The following technique, although it works to answer the question here, leaves a nasty bug behind. The Macro editor font size is huge, and won't restore to normal. Furthermore, although it is a wonderful feature I think, this feature has been removed from LO 5.3+. Guessing rather than fix the bugs, they just decided to retire this feature.

To recover from this bug I had to reset my user profile and then reinstall my MRI extension and also re-install the Java Class path and re-allow macros (Security).


You can set: Menu> Tools | Options | LibreOffice | View | User Interface | Scaling to something like 150%. This will scale everything. Not sure if that helps you or not.

@Ratslinger, et.al., :-(, at least he's not trying to use 5.3. I'm guessing someone might have taken it out thinking it wasn't being used by anyone, or was too much trouble to maintain. Too bad, for when I get more older and can't see as well, as my eyes are already going.


Here's an example at of a table at 150%, (notice that the "Record.." status bar is in the smaller font):

image description
(Note that Ask.LibreOffice.org is additionally scaling this to fixed width).

image description


5.2:

image description

5.3:

image description

edit flag offensive delete link more

Comments

Unfortunately no, holding the CTRL key down while rolling the mouse wheel has no effect. Thanks!

keithostertag gravatar imagekeithostertag ( 2017-03-02 05:14:45 +0200 )edit

@keithostertag, Humm? Does rolling the mouse wheel work otherwise, like for scrolling in your browser, e.g. FireFox or Chrome or the like? And if so, then does Ctrl-mouseWheelRoll work in your browser? It should to zoom, and unzoom. Works in Win 10, Linux Debian/Cinnamon & Ubuntu.

EasyTrieve gravatar imageEasyTrieve ( 2017-03-02 07:46:36 +0200 )edit

@EasyTrieve- The mouse wheel works for scrolling through records, but ctl-mouse wheel doesn't do anything I can see, also tested on a Windows7 machine and still no effect. Is there possibly some other setting that would enable it? For clarification- I'm asking about increasing font size when looking at a table in Base.

keithostertag gravatar imagekeithostertag ( 2017-03-02 18:23:04 +0200 )edit

@Ratslinger- Yes, I see that zoom control in a form, but as you say it isn't part of the table control.

keithostertag gravatar imagekeithostertag ( 2017-03-02 18:24:44 +0200 )edit

@keithostertag, get a new mouse I think.

EasyTrieve gravatar imageEasyTrieve ( 2017-03-03 02:29:48 +0200 )edit

@keithostertag, I got a little more time to look at this. I was wrong. You're right, ctrl-mouse wheel does not zoom tables, only forms.

EasyTrieve gravatar imageEasyTrieve ( 2017-03-03 05:15:34 +0200 )edit

@keithostertag, updated my answer. See if this helps.

EasyTrieve gravatar imageEasyTrieve ( 2017-03-03 05:19:14 +0200 )edit

@EasyTrieve there is no such setting in LO v5.3.0.3

Ratslinger gravatar imageRatslinger ( 2017-03-03 05:45:09 +0200 )edit

@Ratslinger, good that he isn't using 5.3. Is the fact that this is missing a bug in your opinion? (BTW 5.3 still crashes when I close it which is why I'm not using it yet).

EasyTrieve gravatar imageEasyTrieve ( 2017-03-03 07:52:00 +0200 )edit

@EasyTrieve Thanks! Yes, that's better. I'm 62, and those tiny fonts are in fact straining my eyes. Your example looks good because your example only has a few records- in a full screen listing (of 74+ records) the font starts crowding the cell lines, so 150% is about the max that looks good. I don't know how to post a screen capture in the comments section to show you.

keithostertag gravatar imagekeithostertag ( 2017-03-03 15:09:32 +0200 )edit
0

answered 2017-03-02 06:02:41 +0200

Ratslinger gravatar image

Part of the problem is using the tiling manager. The base screen becomes proportionate to the tiled area. To increase the items so they are larger you can use the Zoom in the lower right corner (or View->Zoom from the menu) to increase the form items: image description

but this will not increase the frame surrounding the form or the icons. It will also mean lots of scrolling around.

Now if you are actually talking about the Font size, that is controlled differently depending upon what you are dealing with. The form background is just like a Writer doc. Whatever is typed directly on the form is controlled thru the Formatting toolbar. Text within controls is set within the control properties. Unfortunately this does not include the Table control. This seems to be buried deep within the control.

edit flag offensive delete link more

Comments

@keithostertag First you are doing a couple of things wrong using comments and ID's. You placed a comment to me under the wrong answer. With the ID you are attaching the - directly to the name and with that it is an invalid ID - SB @Ratslinger - and not @Ratslinger-. Also you need to be more careful on reading what is said in answers & comments. Nothing was ever stated that Zoom did not work for a Table control, just the controlling of the actual font size. It will zoom with rest.

Ratslinger gravatar imageRatslinger ( 2017-03-03 02:15:35 +0200 )edit

Just to be clear, Zoom and Font size are two DIFFERENT things. Zoom is like looking through a magnifying glass. Font size changes the character size itself an has no effect on the container it is within so a large font in a text box may easily exceed the actual size of the frame.

Ratslinger gravatar imageRatslinger ( 2017-03-03 02:23:13 +0200 )edit

Thanks for the corrections about the use of this forum user interface.

My tiled table window uses the entire vertical dimension of my screen, one record on each of 74 lines on my screen. That makes the characters pretty small. I want to know how to increase the font size so that, say, maybe 50 records are displayed in the total vertical screen size, making the characters larger and easier to see. I don't want zooming, and it's not available anyway (as you show above) in my table view.

keithostertag gravatar imagekeithostertag ( 2017-03-03 03:56:37 +0200 )edit

Ok. There's the problem. You are talking about viewing a table not anything to do with a form. I know of no way to change font size when viewing tables. But that is not the real problem. I believe this is because of the tiling. It is squeezing the table size you had before you put it into a panel. You should (don't use tiling so just imagining here) go full screen with the table view, reduce its' size by dragging sides or corners then place back in paneled area.

Ratslinger gravatar imageRatslinger ( 2017-03-03 04:25:55 +0200 )edit

For further clarification, there is no zoom menu option under the View menu tab when looking at a table in my system. That's what I meant when I said that zoom does not work for a table- it is simply not an available option through the Base menu interface. I was hoping someone would tell me a key combo, menu option or configuration option for increasing the font size when viewing a table.

keithostertag gravatar imagekeithostertag ( 2017-03-03 04:26:31 +0200 )edit

I checked again on a Windows7 machine, and it is no different from my Linux tiled window system. So the issue is not due to tiling on the tiled window manager.

keithostertag gravatar imagekeithostertag ( 2017-03-03 04:32:03 +0200 )edit

Maybe the real lesson for me to learn here is... perhaps it is not so common for people to spend time viewing tables. Perhaps most people rely on forms and/or reports, and I should become more comfortable with using them instead of relying on table views. That's another product of being a beginner and not having a clear picture of what to expect in terms of the power and common use of certain features.

keithostertag gravatar imagekeithostertag ( 2017-03-03 04:39:23 +0200 )edit

So you are saying the table shows OK on a Windows 7 machine?

Ratslinger gravatar imageRatslinger ( 2017-03-03 04:39:48 +0200 )edit

Also, can't you change the resolution in a tiled area? This may be another potential problem.

Ratslinger gravatar imageRatslinger ( 2017-03-03 04:42:17 +0200 )edit

I see in the the i3 guide you can also change fonts. Again, it appears it is something in the tiling program.

Ratslinger gravatar imageRatslinger ( 2017-03-03 04:58:00 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-03-02 04:33:24 +0200

Seen: 754 times

Last updated: Mar 07 '17