Ask Your Question
0

How do I force Calc to use *actual* values to label the x-axis of my chart

asked 2017-03-06 14:51:04 +0100

HWF gravatar image

updated 2017-03-06 14:55:20 +0100

I have a set of numbers, each of which is associated with a date. I want a line chart that shows the numbers with the actual dates as labels of the x-axis. Instead, Calc uses arbitrary (?) but equally spaced dates as labels which means that no number is labelled correctly in the chart. For example, I have (using British date format dd/mm/yy)

01/12/16 121

08/12/16 133

23/12/16 121

30/12/16 114

06/01/17 123

20/01/17 134

03/02/17 109

24/02/17 115

03/03/17 107

but the labels used are 26/11/16, 16/12/16, 05/01/17, 25/01/17, 14/02/17, 06/03/17 and 26/03/17. I want the dates in the data to be used as labels, even thought they are not ecenyly spaced. How? Please.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2017-03-06 15:14:52 +0100

updated 2017-03-06 15:21:25 +0100

Use Text as Axis format.

To set it, enter the chart editing mode (double-click the chart area), then right-click the X(?) axis, and choose Format Axis.... On Scale tab, select Text next to Type.

You may also consider using staggering odd/even labels on Label tab for better readability.

edit flag offensive delete link more

Comments

I'm afraid this does not work. First, there is no Format Axis option on the Scale tab. There is a Format option on the Numbers tab but all the choices are greyed out. If you uncheck the Source Format box on that tab, the choices become available and you can choose Text In the Category pane of the tab. However, if you do that, the x-axis values change to the numbers which are Calc's internal representation of the dates which is something like the number of days since 1 Jan 1900. Please ...

HWF gravatar imageHWF ( 2017-03-07 01:25:56 +0100 )edit

Please pay attention to what you read. The Format Axis... is a menu item in context menu that is available when you right-click the axis. On Scale tab, there is Type combobox, where you can choose Text.

Mike Kaganski gravatar imageMike Kaganski ( 2017-03-07 05:10:35 +0100 )edit

Whoops. Apologies. Your solution works. Thank you. Apologies also for the delay in replying.

HWF gravatar imageHWF ( 2017-03-09 01:32:40 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-03-06 14:51:04 +0100

Seen: 1,182 times

Last updated: Mar 06 '17