Ask Your Question
0

In writer, I'm suddenly getting one less line per page

asked 2017-03-10 01:45:19 +0200

Luke Kendall gravatar image

After making lots of edits to my book today, I noticed there'd been a page creep. I eventually tracked it down to the number of lines per page dropping by 1, because it seems that LO is now reserving an extra blank line at the bottom of the page.

A screenshot that shows a page from an earlier version of the book on the left (before I accidentally changed some setting), and a page from the current version of my book on the right, with the extra blank line area highlighted, is on my web page at image:Old version on left, current version on right

I suppose my question is, "What controls the spacing in this bottom area, near the grey registration marks?" I must have modified the page style, early in the day, accidentally. I clicked the Reset button on the page style, and didn't noticed any change (until 10 hours later!).

I compared every aspect of the Page style I could in that page style, between the earlier book and the new one, but all settings seemed identical. I even tried setting Register-true (didn't help), and activating Asian languages so I could use the Text Grid and change the number of lines: but that seems to be altering the font and leading, while still leaving the new blank line reserved at the bottom of the page.

There's also the occasional rare page that doesn't have the extra blank line at the bottom: the first one occurs on p185. It is the same page style ("Convert8"), and examining every tab of the page format, I can see no difference for this page. But it has the number of lines per page that I want. p185, p188-190, and p513 are also correct.

Please help!

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2017-03-10 09:24:23 +0200

JohnHa gravatar image

updated 2017-03-10 09:25:06 +0200

Compare all the settings in the old and new files.

In particular, check:

1 Format > Paragraph > Indents&Spacing > Gap above or below etc

2 Format > Page ... have you increased the bottom margin? or header or footer depth or gap? Does reducing the top or bottom margin slightly fix it?

3 Have you increased the font size slightly? Or changed the Format > Character > Position settings? Or made the footer font bigger?

edit flag offensive delete link more
0

answered 2017-03-10 02:33:27 +0200

LibreTraining gravatar image

updated 2017-03-15 21:42:19 +0200

I analyzed your file, found a solution, and answered in your bug report.
Bug 106476 - Page formats vary although all page style settings are identical

A quick summary:
- Deleted all manual formatting
- Page height was set to 7.99 in., changed that to 8.00 in.

Now text-only pages go to the bottom of the page (they fit).
Chapter Title pages still have a space because the font sizes and paragraph before/after settings are a mix of point and inches - which do not fit evenly within the vertical margins.

To make everything fit exactly you would need to use points and picas for all measurements.
That way you can calculate all settings to fit in a vertical grid such as 12 points.

Please click the checkmark if this answers your question.

.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-03-10 01:45:19 +0200

Seen: 98 times

Last updated: Mar 15 '17