Ask Your Question
0

Labels populates table cells with database field names, not addresses

asked 2017-03-15 20:14:41 +0100

Techdork gravatar image

updated 2017-03-15 20:32:41 +0100

I want to print mailing address labels. Following the instructions as best i can tell, which are two largely similar versions of the same process: https://help.libreoffice.org/Common/C... https://help.libreoffice.org/Common/P...

When I click New Document, I get an .odt page full of 30 tables perfect for printing on labels, but the contents of each table is the spreadsheet column title/database field name, repeated 30 times, instead of 30 names/addresses, like this with a gray background:

<name>

<city><st><zip>

For some reason Address in brackets isn't appearing above. I'm able to print a sheet of my return addresses no problem.

What do i need to do?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2019-02-13 18:04:36 +0100

And this thread answered it for me:

https://ask.libreoffice.org/en/question/139605/having-trouble-populating-a-table-with-a-spread-sheet/

If you have the database already setup for the labels, and do File > New > Labels, and have already selected your database source, when you click "New Document", there is an additional step.

You must do a mail merge Tools > Mail Merge and click Next, then Finish. This brings up a button toward the top of the window that says "Edit individual documents".

From there, it'll create a new document with the data populated from the database, using the template you just created.

edit flag offensive delete link more
0

answered 2017-03-16 00:09:32 +0100

m.a.riosv gravatar image

Please test with the option Menu/View/Field names

edit flag offensive delete link more

Comments

ok this is how it copy/pastes, but it does not look like this on my display: <name>

<city><st><zip>

This is how it looks: Branch Mailing Address Labels.Sheet1.Name Branch Mailing Address Labels.Sheet1.Address Branch Mailing Address Labels.Sheet1.City [and so on]

This is what shows in Inscription Label text, transferred after selecting the Database and Table and Database field and then the Left Arrow: <branch mailing="" address="" labels.sheet1.0.name=""> <branch mailing="" address="" labels.sheet1.<="" p="">

Techdork gravatar imageTechdork ( 2017-03-16 02:35:30 +0100 )edit

to confirm; what i copy/pasted above that looks like the 2nd paragraph above is what shows in View > Fieldnames

Techdork gravatar imageTechdork ( 2017-03-16 02:38:31 +0100 )edit

Did this ever get resolved? If so, how? I am having the exact same problem

jackozark@gmail.com gravatar imagejackozark@gmail.com ( 2018-12-15 15:11:32 +0100 )edit

I would like to add to this also. I have the exact same problem. It happened to me on version 5, and I am on 6.1.4.2 now, and the issue is the same.

LibOffFan gravatar imageLibOffFan ( 2019-02-13 17:54:25 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-03-15 20:14:41 +0100

Seen: 187 times

Last updated: Feb 13