Ask Your Question

Building LibreOffice in Cygwin leads to infinite loop.

asked 2017-03-16 12:11:34 +0100

vovakotik gravatar image

updated 2017-03-16 13:25:27 +0100

I try to build LibreOffice for Windows using Cygwin as it written is the instruction. I use autogen with such params:

./ --with-external-tar=./../lo-externalsrc --without-java --enable-pch --disable-ccache --disable-activex --disable-atl --enable-64-bit --enable-dbgutil --enable-debug

After configuring I run:

/opt/lo/bin/make --debug

And I have this output:

cygwin shell

It may repeat infinitly. I use Visual Studio 2013, so I clone the repository before its support was dropped. How can I fix this?

edit retag flag offensive close merge delete


What is --debug in your /opt/lo/bin/make --debug?

The development problems are better solved in #libreoffice on FreeNode. Also, you may connect to #libreoffice-ru.

Mike Kaganski gravatar imageMike Kaganski ( 2017-03-16 12:37:43 +0100 )edit

This flag adds some more strings to output. Because of it I get for example: Re-executing[443]: C:/cygwin64/opt/lo/bin/make -j 4 -rs -f D:/lo/core/Makefile.gbuild all GNU Make 4.2.1 Built for Windows32 Copyright (C) 1988-2016 Free Software Foundation, Inc. License GPLv3+: GNU GPL version 3 or later This is free software: you are free to change and redistribute it. There is NO WARRANTY, to the extent permitted by law. Reading makefiles...

vovakotik gravatar imagevovakotik ( 2017-03-16 13:02:00 +0100 )edit

Without this flag I only have infinitely repeating lines on output.

vovakotik gravatar imagevovakotik ( 2017-03-16 13:05:01 +0100 )edit

Now that I look at your autogen: 1. The --enable-dbgutil and --enable-debug are mutually exclusive. --enable-dbgutil gives more debug possibilities, and takes more resources; 2. Why do you need --disable-activex and --disable-atl? I remember having problems with those (it was long ago; I had only express SKU that time; and iirc I had to use WDK to enable them to succeed).

Mike Kaganski gravatar imageMike Kaganski ( 2017-03-16 13:19:14 +0100 )edit

Also, just a notice that it's better to put the config options to autogen.input. I don't know if that matters, but I have --with-external-tar set to absolute path (/cygdrive/d/sources/lo-externalsrc). I don't see --with-ant-home=/path/to/ant in your config.

Mike Kaganski gravatar imageMike Kaganski ( 2017-03-16 13:21:49 +0100 )edit

Earlier I built LibreOffice in Cygwin without installing Ant. It worked. So, now I installed it and have autogen input: --with-external-tar=/cygdrive/d/libre/lo-externalsrc --with-ant-home=/cygdrive/d/libre/apache-ant-1.9.5 --without-java --enable-pch --disable-ccache --enable-64-bit --enable-dbgutil

But I still have the same result: infinite loop, re-executing of make.

vovakotik gravatar imagevovakotik ( 2017-03-16 13:41:35 +0100 )edit

did you make clean?

Mike Kaganski gravatar imageMike Kaganski ( 2017-03-16 13:43:16 +0100 )edit

I try to make building in folder /cygdrive/d/libre/core

vovakotik gravatar imagevovakotik ( 2017-03-16 13:44:02 +0100 )edit

I really advice you to join #libreoffice on IRC. But I'm afraid that there will arise a question why do you use VS2013. I suppose that's not a real problem, and I myself used 2013 ~two weeks ago, but...

Could that be that you happen to checkout to a problematic commit?

Mike Kaganski gravatar imageMike Kaganski ( 2017-03-16 13:59:08 +0100 )edit

I use VS2013 because I have its license for a professional version and I can't use community edition. I tried different commits on different machines with the same result. This is strange, because recently (in February) building was successful. I really don't know why it began re-executing after.

vovakotik gravatar imagevovakotik ( 2017-03-16 14:14:41 +0100 )edit

1 Answer

Sort by » oldest newest most voted

answered 2017-07-26 15:57:53 +0100

vmiklos gravatar image is my attempt to address that.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower


Asked: 2017-03-16 12:11:34 +0100

Seen: 298 times

Last updated: Jul 26 '17