libreoffice headless listening mode - not working if not root

asked 2017-03-26 00:18:29 +0100

luke_80 gravatar image

updated 2017-04-02 20:03:39 +0100

I'm trying to convert a docx file to pdf using LibreOffice headless. I started the server in listening mode, cause it seems the way to go to use it concurrently and for performance benefits (I'm planning to use it in a web application) as:

libreoffice --headless --accept="socket,host=localhost,port=9997,tcpNoDelay=1;urp" --nodefault --nofirststartwizard --nolockcheck --nologo --norestore --invisible

however, as normal user, the following command does not work, without any output (errors or messages):

libreoffice --headless --convert-to pdf --infilter="Microsoft Word 2007/2010/2013 XML" LaP1.docx

running it as root, instead, it works.

Anybody experienced that and can provide any help?

I'm running Ubuntu 16.04.2 LTS Ubuntu 16.04.2 LTS.

edit retag flag offensive close merge delete