Ask Your Question
0

Time entry in H:M:S mysteriously switches to have a stopwatch character

asked 2017-03-26 03:25:59 +0200

ujhmh gravatar image

updated 2017-03-26 03:28:32 +0200

I am seeing a bizarre behavior when I format a colum to have "Time HH:MM:SS" format. When I start to enter the time, say 5:10:20 when I get to the second colon it switches to 5๐Ÿ•™ and then ends up as 5๐Ÿ•™20 when I finish adding the seconds. This is totally repeatable, when the hours are 0 through 12. If the hours are 13 or greater the problem does not occur. My workaround is to put in a bogus HH value and then edit it to the correct value after the entry in complete, but that is not the proper way for the time entry to work. I am using LibreOffice 5.1.6.2 and my OS is Ubuntu 16.04 LTS.

edit retag flag offensive close merge delete

Comments

Are you sure there isn't a silly add-in to LibO - or probably on the OS level?
What is your locale and your UI-language? Is there a need to disambiguate two formats for numeric values of different type both using the colon? Was the setup for your OS / LibO made by someone regularly using the colon notation wrongly meant to denote mm:ss when entering durations? If you enter such a TOD value into a 'Default' style cell: What 'Numbers' format code is the cell set to automatically?

Lupp gravatar imageLupp ( 2017-03-26 13:08:16 +0200 )edit

In addition: The described behaviour might indicate the presence of a keyboard listener under LibO which was registered and assigned to a handler intentionally producing the described behaviour. Do you experience a similar behaviour under some conditions in Writer? Did you inspect your "macros" libraries for code suspect under this assumption?

Lupp gravatar imageLupp ( 2017-03-26 13:25:37 +0200 )edit

I will look for those things. My OS is a stock install of Ubuntu 16.04.2 LTS with English. LibO is a default package in that OS install. I didn't do any customization of LibO that I am aware of.

ujhmh gravatar imageujhmh ( 2017-03-26 19:33:09 +0200 )edit

As suggested by Lupp I tried entering the same keyboard input to a LibO Writer doc and saw the same character auto-substitution.

ujhmh gravatar imageujhmh ( 2017-03-26 19:36:36 +0200 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-03-26 11:21:38 +0200

Some things I would look to:

  1. Cell locale.
  2. Tools-Options-Language Settings-* sentence checking-Typography (there might be replacements defined)
  3. Tools-AutoCorrect Options...
  4. Font?
edit flag offensive delete link more

Comments

Bingo. There are a bunch of emoticon substututions defined that I will now be sending into the bit bucket. Thanks.

ujhmh gravatar imageujhmh ( 2017-03-26 19:44:44 +0200 )edit

Just to be clear in case someone else has this same issue. The problem was introduced by entries under option (3) "Tools"->"AutoCorrect Options...". For all N = {1..12} there is an entry that changes ":N:" to a clock face with the hour hand in that position. There are a lot more that have the format ":X:" where some other emoticon substitution is performed. 'Cause you know nothin' makes yer spreadsheet look more professional than emoticons.

ujhmh gravatar imageujhmh ( 2017-03-26 19:56:21 +0200 )edit

I suppose you use English (US) locale? It seems that in 5.3.1. the codes were changed to :X h:.

Mike Kaganski gravatar imageMike Kaganski ( 2017-03-26 20:04:13 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-03-26 03:25:59 +0200

Seen: 58 times

Last updated: Mar 26 '17