Ask Your Question
1

In Base using Report builder header and footer not created - Resolution

asked 2017-03-29 14:39:17 +0200

ezrapound gravatar image

updated 2017-05-06 21:54:57 +0200

A recent update seems to be the culprit. I've tried various options but I cannot get header and/or footer created. Version is 5.2.5.1 Build 20M0 on OpenSUSE Leap 42.1.

If I edit the generated report and edit the header/footer by setting automatic height, I get my report.

edit retag flag offensive close merge delete

Comments

Have used most versions since 4.4.x and currently on v5.3.1.2 using Mint 18. Have not seen this problem nor is it present as of test just now. My versions all come directly from LO. Are you using a distro version? Occasionally this can be a problem. Can you provide a sample of your problem. Have given Karma to allow you to upload; post in original question by using the edit selector at bottom right of your question.

Ratslinger gravatar imageRatslinger ( 2017-03-29 17:28:08 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2017-04-24 23:24:47 +0200

Ratslinger gravatar image

It appears this is an OpenSuse problem (not the first I've come across). Using Mint 18 and LO v5.3.2.2 (from LO not distro) I see no problems. In many other versions I have not seen the problem either. Screenshot direct from download:

image description

Print preview:

image description

edit flag offensive delete link more

Comments

Thanks for confirmation.

branestawm gravatar imagebranestawm ( 2017-04-28 16:06:13 +0200 )edit
0

answered 2017-04-17 00:00:08 +0200

branestawm gravatar image

updated 2017-04-24 21:06:09 +0200

I have the same issue with reports generated for Writer, having upgraded from LO v5.1.3 to v5.2.6.2 Build 20m0(Build:2) on OpenSuse 13.2, release supplied by SUSE. Report Builder appears to be more stable in this release, but this irritating new issue has arisen.

Page headers & footers are in fact created but they are not visible in the report document. You need to set Format -> Page -> Header/Footer -> Autofit height in each report document, whereupon the headers & footers magically appear.

I have a simple test database (8KB) which demonstrates this behaviour but I can't see how to upload it here.

Presumably there is a setting to enable this by default - it's tedious to have to do it for each report - but I can't find it. Setting this in the Normal template does not solve the issue. Does anybody know where the setting is? Or is this a bug?

headertest.odb

edit flag offensive delete link more

Comments

To attach a file, edit your answer (lower right of answer) and select from the toolbar the paperclip (attachment). Would like to see since I can't reproduce the problem.

Ratslinger gravatar imageRatslinger ( 2017-04-17 00:27:15 +0200 )edit

I have uploaded test database headertest.odb

[Sorry for delay - I've only just realised that I have to login to see the answer edit link]

branestawm gravatar imagebranestawm ( 2017-04-24 21:08:10 +0200 )edit

I've now replaced the OpenSuse distro edition of LO with same version downloaded directly from TDF - this has resolved the issue for me. Evidently it's important to realise that distro editions can be significantly different from master editions, eg install and config subfolders are different for each edition.

OpenSuse users doing the same may want to restore the soft link to 'soffice' (ln -s /usr/bin/soffice /opt/libreoffice5.2/program/soffice)

Thanks to @Ratslinger for your interest & help.

branestawm gravatar imagebranestawm ( 2017-04-30 17:57:05 +0200 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2017-03-29 14:39:17 +0200

Seen: 304 times

Last updated: May 06 '17