Ask Your Question
0

Problem with saving CSV with carriage return [closed]

asked 2012-12-17 12:09:56 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I need to save my LO calc file as a comma delimited CSV to import into another system.

It requires a return at the end of each row but the character is incorrect.

Is there an option to change the row end character?

What is the default character? It appears to be a normal return but if I delete it and replace with a normal return the import works fine.

Thanks for your help.

Kevin

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-19 13:53:29.235058

1 Answer

Sort by » oldest newest most voted
0

answered 2012-12-18 04:22:21 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

This is not an answer; it's a workaround.

CSV is a simple text format, but there are variations in delimiters across programs. I had no problem moving data (saved from Libre Calc as .csv) into other programs. So I'll venture a guess that your receiving software may be looking for a particular form of delimiter that's a bit out of the ordinary.

Instead of CSV, try using Data Interchange Format. DIF is perhaps the oldest widely used spreadsheet-compatible format, and is precisely formated. It is supported by nearly all programs that process spreadsheet-styled data. From Libre Calc, "Save As" .dif and try to pull it into your system.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-12-17 12:09:56 +0200

Seen: 1,771 times

Last updated: Dec 18 '12