Ask Your Question
0

Exporting to XHTML with conditional formatting doesn't work [closed]

asked 2012-12-18 17:21:25 +0200

anonymous user

Anonymous

updated 2015-10-19 13:46:53 +0200

Alex Kemp gravatar image

I am using LibreOffice 3.6.4.3. I have tried to export a document that uses conditional formatting to change the cell's background color to XHTML. Any colors that are set using what I call "normal formatting" (i.e. Right click on cell -> Format Cells -> Background Tab -> choose light red -> click OK) export correctly when I use the export function (File -> Export -> Save as type XHTML). However, any cells that are conditionally formatted (Format -> Conditional Formatting -> Conditional Formatting...) do not have their colors exported. In my specific case, I have three layers of formatting, the first checks if ISNA(E2) and leaves the background as No Fill, the second checks if the value is less than D2 and sets the background to red, and the third checks if it is greater than D2 and sets it to green. When I do an export where cells are conditionally formatted with a red background, the "normal formatting" gets exported correctly, but the conditional formatting does not.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-19 13:47:04.478160

1 Answer

Sort by » oldest newest most voted
0

answered 2012-12-23 15:01:38 +0200

qubit gravatar image

updated 2012-12-23 15:02:03 +0200

Hi @Anonymous,

This situation looks like a good candidate for a bug report: https://www.libreoffice.org/get-help/bug/

Could you please file a bug and attach

  • The original file
  • The exported XHTML file

Please mention in the bug report what discrepancies you observe between the original file and the export.

Thanks!

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-12-18 17:21:25 +0200

Seen: 177 times

Last updated: Dec 23 '12